El reenvío de registros desde CDL a Splunk se detiene o el flujo es intermitente

El reenvío de registros desde CDL a Splunk se detiene o el flujo es intermitente

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Created On 02/02/24 21:34 PM - Last Modified 01/03/25 13:42 PM


Symptom


  • Problema intermitente en el que Splunk no recibía registros de CDL
  • El Panel de CDL para el reenvío de logs mostró un flujo incompleto o intermitente


Environment


  • Cortafuegos
  • Reenvío de registros
  • Licencia CDL
  • Splunk



Cause


Una o más causas provocan el problema por el cual el reenvío de logs se detiene ocasionalmente.

  • Conexión TCP inestable entre CDL y el servidor Splunk
  • Problemas de SSL/TLS debido a la caducidad del certificado o a una negociación de SSL fallida entre CDL y el servidor Syslog de Splunk
  • Si hay algún problema subyacente del backend de CDL que afecte al "mecanismo de reenvío de registros",


Resolution


Existen muchos problemas que podrían afectar el reenvío de logs. Es importante investigar los problemas tanto de Splunk como de CDL para mantener una conexión estable. A continuación, se incluye una lista de algunos ejemplos.

  1. Asegúrese de que haya una conexión TCP/ SSL estable entre Splunk y CDL. Una conexión inestable provoca la pérdida de datos, por lo que es posible que el mecanismo no vuelva a enviar los mensajes de syslog perdidos.
  2. Asegúrese de que el certificado sea válido
  3. Una prueba de conectividad de red regla un punto de datos


Additional Information


Servicio de registro de Strata Reenvía registros a un servidor Syslog



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