Push failed in newly deployed tenant with error "Failed to find infrastructure subnet in onboarding-config.Failing commit!" in Prisma Access Managed by Strata Cloud Manager
2391
Created On 01/23/24 20:23 PM - Last Modified 05/22/25 21:22 PM
Symptom
- Prisma Access Tenants are newly Deployed.
- These tenants are managed by Strata Cloud Manager.
- Under Workflows > Prisma Access Setup > Infrastructure Settings > Infrastructure Subnet is auto-populated with default subnet (192.168.255.0/24)
- Configuration is pushed without changing the default configuration in Infrastructure Settings.
- This displays error message "Failed to find infrastructure subnet in onboarding-config.Failing commit!".
Environment
- Prisma Access
- Strata Cloud Manager
- Prisma Access Cloud Managed
Cause
- The Prisma Access newly deployed tenants will show with the default Infrastructure subnet settings in Strata Cloud manager > Workflows > Prisma Access Setup > Prisma Access > Infrastructure Settings
- When the default configuration is not changed and a push is performed, the validation will be successful but the push to Mobile Users, Remote Networks, and Service Connection will fail.
- When we click the job id, it will show the error "Failed to find infrastructure subnet in onboarding-config.Failing commit!".
Screenshots below:
Resolution
Click on the gear icon of the Prisma Access Setup > Infrastructure Settings and then save it and push the config.
Additional Information
- This is expected behavior because the infrastructure subnet is mandatory and it can not be changed once it is being pushed.
- The user needs to confirm auto-populated infrastructure subnet by clicking the gear icon and save it even if the subnet is same for the production as well.
- Click here to get more details on the configuration steps.