GlobalProtect Transparent upgrade not being initiated when Portal status is "Using cached portal config".
3803
Created On 01/23/24 10:18 AM - Last Modified 08/23/24 21:09 PM
Symptom
- GlobalProtect Transparent upgrade not being processed when Portal status remains as "Using cached portal config".
- The following logs are seen in PanGPS.log.
43:447 ----Portal Pre-login starts----
43:457 Network is not available
43:457 Failed to get portal config from portal ****.gpcloudservice.com
43:457 Try to restore last portal config from file.
43:503 last portal config is restored from file C:\Users\***\AppData\Local\Palo Alto Networks\GlobalProtect\PanPortalCfg_f3ee8ae*******373b1373456.dat.
...
43:580 portal status is Using cached portal config.
Environment
- GlobalProtect(GP) App
- Version 6.1.2 and below
- Version 6.0.7 and below
Cause
- When GP Portal is not reachable during initial connection, the client uses cached config.
- This is indicated in the message "Using cached config".
- Since the portal is not reachable, the transparent upgrade cannot be initiated.
- When the portal is back online, still the upgrade is not initiated as the portal status is decided by the initial portal connection.
Resolution
- The issue is fixed under GPC-16267 in versions 6.0.7 and 6.1.2.
- Upgrade to the above versions or higher will resolve the issue.