Prisma Cloud & Compute: Defender Connection with Console fails with Warning "Web socket is nil"
2005
Created On 01/03/24 10:25 AM - Last Modified 04/30/24 09:35 AM
Symptom
- Defender connection with the Console fails with the following error
DEBU 2023-12-03T17:29:35.665 ws.go:342 Reconnecting to wss://asia-southeast1.cloud.twistlock.com:443 queue: 1168 DEBU 2023-12-03T17:29:36.266 ws.go:202 Stopping web socket ERRO 2023-12-03T17:29:36.267 ws.go:429 Defender version 22.12.699 is unsupported against current console version. A manual upgrade is required to activate the defender DEBU 2023-12-03T17:29:36.267 ws.go:374 Connection failed. Sleeping 2.00 [s] websocket: bad handshake WARN 2023-12-03T17:29:38.267 ws.go:470 Web socket is nil WARN 2023-12-03T17:29:39.267 ws.go:470 Web socket is nil WARN 2023-12-03T17:29:40.267 ws.go:470 Web socket is nil
Environment
- Prisma Cloud and Compute
Cause
- The errors / warnings related to Web socket are seen in the defender logs when there is an supported defender version against the Console's current version
ERRO 2023-12-03T17:29:36.267 ws.go:429 Defender version 22.12.699 is unsupported against current console version. A manual upgrade is required to activate the defender DEBU 2023-12-03T17:29:36.267 ws.go:374 Connection failed. Sleeping 2.00 [s] websocket: bad handshake WARN 2023-12-03T17:29:38.267 ws.go:470 Web socket is nil
Resolution
- Upgrade the defender to the latest version
- Ensure that the defender's version is at least n-2 as compared to the Console's current version. Prisma Cloud has an 'n-2' support policy, which means the current release ('n') and the previous two releases ('n-1' and 'n-2') receive support
Additional Information
Reference document: Prisma Cloud Supported Version Policy