受监控的用户在 Strata Cloud 管理器监控用户报告中显示多个用户的重复设备名称/位置。
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Created On 12/30/23 03:44 AM - Last Modified 02/20/25 01:31 AM
Symptom
- Strata 云管理器上的监控 > 用户部分显示通过 Global Protect 连接的用户状态以及经验分数。
- 为当前用户和设备导出的报告显示多个用户的设备名称重复,即使他们是不同的物理机器和唯一的用户名。
- 如上图所示,device_name 对于多个用户来说是重复的。
- 这仅发生在受 ADEM 监控的用户身上。
- 在用户位置上也可以观察到相同的行为。
- 这仅对 Windows 用户可见。
Environment
- ADEM(自主数字体验管理)监控用户。
- Strata Cloud 管理器监控 > 用户部分。
- Prisma Access 供用户使用。
- 仅限 Windows 操作系统。
Cause
- 发生这种情况的原因是用户端的 Windows 全局唯一标识符 (全局唯一标识符)相同/重复。
- ADEM 根据安装 DEM 代理时收到的唯一 GUID 检索主机名/设备名称和其他属性。
- 期望所有用户都应该有唯一的 GUID。
- 在部署期间克隆机器操作系统时可以创建重复的 GUID。
Resolution
- 与 IT 团队合作,确保所有 Windows 机器都有唯一的 GUID。
- 一旦 GUID 唯一,请为受影响的用户禁用 ADEM用户体验(这将为他们卸载 DEM 代理)
- 完成后,从门户再次启用它以再次安装 DEM 代理,新数据应显示正确的唯一设备名称而不是重复项。
- 请参阅本指南来启用/禁用 ADEM。
Additional Information
- 云管理器或 ADEM 代理上没有问题。
- Windows GUID 应该是唯一的,并且是操作系统安装/部署或操作系统供应商的问题。
- 这也记录在 ADEM 已知问题发布说明中。(搜索 DEM-3992)
- 要查明并确认 Windows GUID 在唯一用户中是否相同,请收集 GlobalProtect 日志
- 提取压缩的日志包并打开日志文件“ palo_alto_networks_dem_agent.log ”
- 在日志中搜索 uuid,它将是从客户端获取的 GUID。如果它们对于 2 个唯一用户相同,则上述场景将适用。
[2023-12-24 15:12:31.706] [default] [info] Received inbound message:
SeqNum 923697
MsgId 24201 (unknown)
Flags 64
Payload: {"user":"user@customer.com","groups":[],"groupsTimestamp":1703419964}
[2023-12-24 15:12:32.855] [default] [info] Serialised message:
MsgId: 24001 (MSGIDS_AGENT_STARTUP_REQUEST)
SeqNum: 14097
Payload: {
"utcTime": "20231224-12:12:31.554+180",
"version": "4.0.11",
"uuid": "xxxxxxxx-xxxx-xxxx-xxxx-yyyyyyyyyyyy", <<<<<<. (Masked on purpose)
"accountId": 4661,
"network": {
"wlans": [
{
"active": true,
"ssid": "user_name",
"minRx": 173300,
"rx": 173300,
"maxRx": 173300,
"minTx": 173300,
"tx": 173300,
"maxTx": 173300,