Les utilisateurs surveillés affichent le nom de périphérique / l'emplacement en double pour plusieurs utilisateurs dans le rapport Surveiller les utilisateurs de Strata Cloud Manager.
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Created On 12/30/23 03:44 AM - Last Modified 02/20/25 01:25 AM
Symptom
- La section Monitor > Users du gestionnaire de cloud Strata affiche les états des utilisateur connectés par Global Protect ainsi que le score d'expérience.
- Le rapport exporté pour les utilisateurs et les appareils actuels affiche un nom d'appareil en double pour plusieurs utilisateurs, même lorsqu'il s'agit de machines physiques différentes et de noms d'utilisateur uniques.
- Comme le montre la capture d’écran ci-dessus, le device_name est dupliqué pour plusieurs utilisateurs.
- Cela ne se produit que pour les utilisateurs surveillés par ADEM.
- Le même comportement peut également être observé pour les emplacements des utilisateur .
- Ceci est observé uniquement pour les utilisateurs Windows.
Environment
- ADEM (Autonomous Digital Experience Management) a surveillé les utilisateurs.
- Gestionnaire de cloud Strata Monitor > Section Utilisateurs.
- Prisma Access pour les utilisateurs.
- Système d'exploitation Windows uniquement.
Cause
- Cela se produit en raison d' un GUID Windows (identifiant unique global) identique/dupliqué du côté des utilisateurs.
- L'ADEM récupère le nom d'hôte/ nom_périphérique et d'autres attributs en fonction du GUID unique reçu lors de l'installation de l'agent DEM.
- L’attente est que tous les utilisateurs aient un GUID unique.
- Des GUID en double peuvent être créés lorsque le système d'exploitation des machines est cloné pendant le déploiement.
Resolution
- Travaillez avec l’équipe informatique pour vous assurer que toutes les machines Windows ont un GUID unique.
- Une fois le GUID unique, désactivez l'expérience utilisateur ADEM pour les utilisateurs concernés (cela désinstallera l'agent DEM pour eux)
- Une fois cela fait, réactivez-le à partir du portail pour réinstaller l'agent DEM et les nouvelles données devraient afficher des noms d'appareils uniques corrects au lieu de doublons.
- Reportez-vous à ce guide pour activer/désactiver ADEM.
Additional Information
- Il n'y a aucun problème ici sur le gestionnaire Cloud ou l'agent ADEM.
- Le GUID Windows doit être unique et constitue un problème d'installation/déploiement du système d'exploitation ou de fournisseur du système d'exploitation.
- Ceci est également documenté dans les notes de publication des problèmes connus d'ADEM ici . (Recherchez DEM-3992)
- Pour savoir et confirmer si le GUID Windows est le même pour les utilisateurs uniques, collectez les journaux GlobalProtect
- Extraire le bundle de journaux compressés et ouvrir le fichier journal « palo_alto_networks_dem_agent.log »
- Recherchez l'UUID dans les journaux qui correspondra au GUID obtenu auprès du client. S'ils sont identiques pour 2 utilisateurs uniques, le scénario ci-dessus serait applicable.
[2023-12-24 15:12:31.706] [default] [info] Received inbound message:
SeqNum 923697
MsgId 24201 (unknown)
Flags 64
Payload: {"user":"user@customer.com","groups":[],"groupsTimestamp":1703419964}
[2023-12-24 15:12:32.855] [default] [info] Serialised message:
MsgId: 24001 (MSGIDS_AGENT_STARTUP_REQUEST)
SeqNum: 14097
Payload: {
"utcTime": "20231224-12:12:31.554+180",
"version": "4.0.11",
"uuid": "xxxxxxxx-xxxx-xxxx-xxxx-yyyyyyyyyyyy", <<<<<<. (Masked on purpose)
"accountId": 4661,
"network": {
"wlans": [
{
"active": true,
"ssid": "user_name",
"minRx": 173300,
"rx": 173300,
"maxRx": 173300,
"minTx": 173300,
"tx": 173300,
"maxTx": 173300,