Die überwachten Benutzer zeigen im Bericht „Benutzer überwachen“ des Strata Cloud Managers doppelte Gerätenamen/Standorte für mehrere Benutzer an.
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Created On 12/30/23 03:44 AM - Last Modified 02/20/25 01:27 AM
Symptom
- Der Abschnitt „Monitor > Benutzer“ im Strata-Cloud-Manager zeigt die Benutzer an, die über Global Protect verbunden sind, zusammen mit dem Erfahrungswert.
- Der für aktuelle Benutzer und Geräte exportierte Bericht zeigt doppelte Gerätenamen für mehrere Benutzer, selbst wenn es sich um unterschiedliche physische Maschinen und eindeutige Benutzernamen handelt.
- Wie im Screenshot oben zu sehen ist, wird der Gerätename für mehrere Benutzer dupliziert.
- Dies geschieht nur für Benutzer, die von der ADEM überwacht werden.
- Dasselbe Verhalten lässt sich auch bei den Benutzer beobachten.
- Dies gilt nur für Windows-Benutzer.
Environment
- ADEM (Autonomous Digital Experience Management) überwachte Benutzer.
- Strata Cloud Manager Monitor > Abschnitt „Benutzer“.
- Prisma-Zugriff für Benutzer.
- Nur Windows-Betriebssystem.
Cause
- Dies geschieht aufgrund identischer/doppelter Windows -GUIDs (Globally Unique Identifier) auf der Benutzerseite.
- Der ADEM ruft den Hostname/Gerätenamen und andere Attribute basierend auf der eindeutigen GUID ab, die bei der Installation des DEM-Agenten empfangen wurde.
- Es wird erwartet, dass alle Benutzer eine eindeutige GUID haben.
- Wenn das Betriebssystem der Maschine während der Bereitstellung geklont wird, können doppelte GUIDs erstellt werden.
Resolution
- Arbeiten Sie mit dem IT-Team zusammen, um sicherzustellen, dass alle Windows-Computer eine eindeutige GUID haben.
- Sobald die GUID eindeutig ist, deaktivieren Sie die ADEM - Benutzererfahrung für die betroffenen Benutzer (dadurch wird der DEM-Agent für sie deinstalliert).
- Sobald dies erledigt ist, aktivieren Sie es erneut über das Portal , um den DEM-Agenten erneut zu installieren. Die neuen Daten sollten korrekte, eindeutige Gerätenamen anstelle von Duplikaten anzeigen.
- Informationen zum Aktivieren/Deaktivieren von ADEM finden Sie in dieser Anleitung .
Additional Information
- Hier liegt kein Problem mit dem Cloud-Manager oder ADEM-Agenten vor.
- Die Windows-GUID muss eindeutig sein und ist ein Problem bei der Installation/Bereitstellung des Betriebssystems oder beim Betriebssystemanbieter.
- Dies ist auch in den Versionshinweisen zu bekannten ADEM-Problemen hier dokumentiert. (Suchen Sie nach DEM-3992)
- Um herauszufinden und zu bestätigen, ob die Windows-GUID bei einzelnen Benutzern identisch ist, sammeln Sie die GlobalProtect- Protokolle
- Extrahieren Sie das komprimierte Protokollpaket und öffnen Sie die Protokolldatei „ palo_alto_networks_dem_agent.log “.
- Suchen Sie in den Protokollen nach UUID. Dabei handelt es sich um die vom Client erhaltene GUID. Wenn sie für zwei eindeutige Benutzer gleich sind, trifft das obige Szenario zu.
[2023-12-24 15:12:31.706] [default] [info] Received inbound message:
SeqNum 923697
MsgId 24201 (unknown)
Flags 64
Payload: {"user":"user@customer.com","groups":[],"groupsTimestamp":1703419964}
[2023-12-24 15:12:32.855] [default] [info] Serialised message:
MsgId: 24001 (MSGIDS_AGENT_STARTUP_REQUEST)
SeqNum: 14097
Payload: {
"utcTime": "20231224-12:12:31.554+180",
"version": "4.0.11",
"uuid": "xxxxxxxx-xxxx-xxxx-xxxx-yyyyyyyyyyyy", <<<<<<. (Masked on purpose)
"accountId": 4661,
"network": {
"wlans": [
{
"active": true,
"ssid": "user_name",
"minRx": 173300,
"rx": 173300,
"maxRx": 173300,
"minTx": 173300,
"tx": 173300,
"maxTx": 173300,