GlobalProtect Client tries to connect automatically after reboot even when the connect method is set as On-demand mode

GlobalProtect Client tries to connect automatically after reboot even when the connect method is set as On-demand mode

8607
Created On 12/28/23 00:52 AM - Last Modified 04/26/24 20:54 PM


Symptom


  • The connect Method is set as "On-Demand" mode under App Configurations in Portal setting.
  • GUI: Network > GlobalProtect >  Portals > (portal name) > Agent > (agent name) > App >
screenshot1.png
(P15004-T2152)Info (9803): 12/05/23 14:23:23:766 Connect method is On-Demand
  • After restarting the client PC, the GlobalProtect Client tries to connect automatically.
12/05/23 14:23:23:766 Connect method is On-Demand
12/05/23 14:26:42:233 Received shutdown message
12/05/23 14:27:17:486 ####################### Start PanGPS service (ver: 6.2.2-259) #######################
12/05/23 14:27:37:353 First logon user.
12/05/23 14:27:54:550 ----Portal Processing starts----
12/05/23 14:27:54:555 --Set state to Retrieving configuration...
12/05/23 14:27:54:576 ----Portal Pre-login starts----
12/05/23 14:27:55:334 ----Portal Login starts----
12/05/23 14:27:55:649 ----Network Discover starts----
12/05/23 14:27:56:469 ----Gateway Pre-login starts----
12/05/23 14:27:56:588 ----Gateway Login starts----
12/05/23 14:28:04:601 --Set state to Connected


Environment


  • GlobalProtect (GP) App on Windows
  • App versions 6.2.1 and 6.2.2


Cause


GlobalProtect Client fails to set the registry value.

Resolution


  1. The issue is fixed in GP App version  6.2.3 under GPC-19262.
  2. Upgrade the the fixed version will resolve the issue.
  3. The versions 6.0.10 and 6.1.5 will also include the fix when released.
Workaround: Manually create the UpdateOD and WasOD keys and set them to 1.
  1. Open the registry editor.
  2. Navigate to the directory : \HKEY_CURRENT_USER\SOFTWARE\Palo Alto Networks\GlobalProtect\Settings\<Portal FQDN or IP>.
  3. Add the below two entries via New > DWORD(32-bit) Value.
name: UpdateOD
type: REG_DWORD
Value : 1

name: WasOD
type: REG_DWORD
Value : 1
screenshot3.png
  1. Reboot the client PC.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000008WM4CAM&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail