Jira Integration - error: request failed with status 400: Field „priority” cannot be set.

Jira Integration - error: request failed with status 400: Field „priority” cannot be set.

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Created On 12/07/23 12:25 PM - Last Modified 01/28/25 21:44 PM


Symptom


  • Customers are unable to set up Jira Integration with Prisma due to an error:
"Failed to send alert: failed to send jira test alert, error: request failed with status 400: Field 'priority' cannot be set.
 
  • The screenshot with error:
image.png
 
  • The screenshot serves as proof that the “Priority” has been set in Prisma Cloud:

image.png
 
  • The screenshot serves as evidence that the “Priority” has been successfully set in Jira for the Prisma Cloud project.

image.png
  • The screenshot provides evidence that all settings are correct, and the customer can successfully save the configuration.

image.png
 


Environment


  • Prisma Cloud
  • Jira integration


Cause


  • The cause for this behavior is the incorrect selection of “default priorities” for the Jira project.
image.png

 


Resolution


  • The solution to the problem is to remove “default priorities” from the Jira project and replace them with “system priorities.”

image.png
  • To identify system priorities, simply expand the choices field. The correct priorities should be highlighted in color, while the default ones remain in black.
image.png
  • After selecting the correct “priorities” in Jira, the project client is able to send a test message.
image.png
  • Prisma Cloud test alerts are now visible in the Jira project.

image.png
 


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000008W8vCAE&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail