Le pare-feu n’envoie pas de journaux à syslog avec le journal Syslog-ng affichant « Erreur lors de la résolution du nom d’hôte »
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Created On 11/30/23 08:31 AM - Last Modified 12/19/23 05:19 AM
Symptom
- Syslog ne reçoit pas les journaux du pare-feu
- Journal Syslog-ng affichant « Erreur lors de la résolution du nom d’hôte » :
Nov 27 06:27:07 FWPA1 syslog-ng[24640]: Error resolving hostname; host='splunk-syslog-ghcc.splunk.example.com' Nov 27 06:27:07 FWPA1 syslog-ng[24640]: Initiating connection failed, reconnecting; time_reopen='5'
- dnsproxy.log affichant « Échec de la résolution du nom de domaine » pour le nom d’hôte syslog :
2023-11-29 10:48:19.383 +0000 Warning: pan_dnsproxy_log_resolve_fail(pan_dnsproxy_util.c:651): Failed to resolve domain name:splunk-syslog-ghcc.splunk.example.com AAAA after trying all attempts to name server(s): 10.250.0.1 10.250.0.2
- Le ping vers le nom d’hôte fonctionne correctement :
user@FWPA1> ping host splunk-syslog-ghcc.splunk.example.com PING splunk-syslog-ghcc.splunk.glblint.example.com (10.240.72.88) 56(84) bytes of data. 64 bytes from splunk-syslog-ghcc.splunk.glblint.example.com (10.240.72.88): icmp_seq=1 ttl=252 time=30.0 ms
Environment
- Toutes les plates-formes
- PANOS 9.1, 10.1.9 ou version antérieure, 10.2.4 ou version antérieure
Cause
- Causé par le problème logiciel PAN-208210 où les modifications de configuration syslog apportées à l’adresse IP ou au numéro de port n’étaient pas appliquées sans redémarrer le serveur d’administration.
Resolution
- Mise à niveau vers la version 10.1.10 ou ultérieure, la version 10.2.5 ou ultérieure, la version 11.0.1 ou ultérieure
La solution de contournement actuellement disponible consiste à redémarrer le serveur d’administration, sans impact attendu dans le plan de données :
> logiciel de débogage redémarre process management-server
Additional Information
https://docs.paloaltonetworks.com/pan-os/10-1/pan-os-release-notes/pan-os-10-1-10-known-and-addressed-issues/pan-os-10-1-10-addressed-issues