Die Firewall sendet keine Protokolle an Syslog, wobei das Syslog-ng-Protokoll "Fehler beim Auflösen des Hostnamens" anzeigt
5735
Created On 11/30/23 08:31 AM - Last Modified 12/19/23 05:19 AM
Symptom
- Syslog empfängt keine Protokolle von der Firewall
- Syslog-ng-Protokoll zeigt "Fehler beim Auflösen des Hostnamens":
Nov 27 06:27:07 FWPA1 syslog-ng[24640]: Error resolving hostname; host='splunk-syslog-ghcc.splunk.example.com' Nov 27 06:27:07 FWPA1 syslog-ng[24640]: Initiating connection failed, reconnecting; time_reopen='5'
- dnsproxy.log zeigt "Fehler beim Auflösen des Domänennamens" für den Syslog-Hostnamen an:
2023-11-29 10:48:19.383 +0000 Warning: pan_dnsproxy_log_resolve_fail(pan_dnsproxy_util.c:651): Failed to resolve domain name:splunk-syslog-ghcc.splunk.example.com AAAA after trying all attempts to name server(s): 10.250.0.1 10.250.0.2
- Ping an Hostname funktioniert einwandfrei:
user@FWPA1> ping host splunk-syslog-ghcc.splunk.example.com PING splunk-syslog-ghcc.splunk.glblint.example.com (10.240.72.88) 56(84) bytes of data. 64 bytes from splunk-syslog-ghcc.splunk.glblint.example.com (10.240.72.88): icmp_seq=1 ttl=252 time=30.0 ms
Environment
- Alle Plattformen
- PANOS 9.1, 10.1.9 oder früher, 10.2.4 oder älter
Cause
- Verursacht durch das Softwareproblem PAN-208210 , bei dem Syslog-Konfigurationsänderungen an der IP-Adresse oder Portnummer nicht angewendet wurden, ohne den Management-Server neu zu starten.
Resolution
- Upgrade auf 10.1.10 oder höher, 10.2.5 oder höher, 11.0.1 oder höher
Die derzeit verfügbare Problemumgehung ist der Neustart des Management-Servers, wobei keine Auswirkungen auf der Datenebene zu erwarten sind:
> debuggen Software neu starten Prozess management-server
Additional Information
https://docs.paloaltonetworks.com/pan-os/10-1/pan-os-release-notes/pan-os-10-1-10-known-and-addressed-issues/pan-os-10-1-10-addressed-issues