System logs report "Not enough space to load content to SHM" with increased usage of /dev/shm

System logs report "Not enough space to load content to SHM" with increased usage of /dev/shm

7127
Created On 11/16/23 01:57 AM - Last Modified 12/09/23 01:07 AM


Symptom


  • show system disk-space displays increased usage of /dev/shm (100 percent in this case)

admin@PA-VM-100> show system disk-space

Filesystem      Size  Used Avail Use% Mounted on
/dev/root       6.9G  4.4G  2.2G  67% /
none            3.2G   88K  3.2G   1% /dev
/dev/sda5        16G  7.1G  8.0G  47% /opt/pancfg
/dev/sda6       7.9G  3.1G  4.5G  41% /opt/panrepo
tmpfs           3.5G  3.4G  7.7M 100% /dev/shm
cgroup_root     3.2G     0  3.2G   0% /cgroup
/dev/sda8        21G  274M   20G   2% /opt/panlogs

  • "Not enough space to load content to SHM" is generated on the system log (show log system).
admin@PA-VM-100> show log system direction equal backward | match SHM
high     general        general 0  Not enough space to load content to SHM
high     general        general 0  Not enough space to load content to SHM
high     general        general 0  Not enough space to load content to SHM
high     general        general 0  Not enough space to load content to SHM
high     general        general 0  Not enough space to load content to SHM

 


Environment


  • Palo Alto Firewalls
  • PAN-OS 11.0.x, 10.2.x, 10.1.x


Cause


  • /dev/shm is used for a temporary directory by many processes.
  • Memory issue may lead to the above symptoms


Resolution


  1. The issue is resolved under multiple defects. Example PAN-207604
  2. The issues are resolved in PAN-OS  10.1.12, 10.2.6, 11.0.4, 11.1.0, 11.2.0
  3. Upgrade of PAN-OS to latest versions will fix the issue.
  4. If the issue is still seen after upgrade, Open a case with Support.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000008Vu5CAE&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail