Intermittent cloud database connection failures with system log reporting "CURL ERROR: error signaled by ssl ctx callback"
15446
Created On 10/31/23 03:05 AM - Last Modified 11/03/23 20:24 PM
Symptom
- Unable to connect intermittently to the elected cloud server (Example: serverlist2.urlcloud.paloaltonetworks.com)
- system log (show log system) indicates Curl error
info url-fil cloud-e 0 CLOUD ELECTION: serverlist2.urlcloud.paloaltonetworks.com IP: 10.x.x.253 was elected, measured alive test 83542.
high url-fil url-clo 0 CURL ERROR: error signaled by ssl ctx callback
- Devsrv.log (less mp-log devsrv.log) too display the same error
+0000 Cloud serverlist3.urlcloud.paloaltonetworks.com
+0000 URL HTTPS://serverlist3.urlcloud.paloaltonetworks.com:443/hello2 IP 10.x.x.253
+0000 Source IP 10.y.y.226
+0000 name lookup time 0.000022 second
+0000 connect time 0.006282 second
+0000 ssl connect time 0.000000 second
+0000 total time 0.014606 second
+0000 server certificate chain: 0 certinfo(s)
+0000 curl error: error signaled by ssl ctx callback
+0000 fail to set thermite client cert in pandb ssl ctx, fallback to use old client cert
+0000 sending alive request msg with len 192
+0000 CLOUD_ELECTION: in wait_t 0 secs.Environment
- Palo Alto Firewalls
- PAN-OS 10.1.10 or below; 10.2.5 or below
- URL Filtering
Cause
Wrong certificates were being used to try and connect to the URL cloud, which will get rejected.
Resolution
- The issue has been addressed under PAN-216775 in PAN-OS 10.1.11, 10.2.6, 11.0.3 and 11.1.0.
- Upgrade of the PAN-OS will resolve the issue.
- If workaround is needed, contact Support and mention this knowledge article.