登录前连接:SAML 身份验证导致屏幕空白
11154
Created On 04/29/24 11:22 AM - Last Modified 10/23/25 00:10 AM
Symptom
- 客户已配置登录前连接 (CBL)。
- 使用 SAML 对 GlobalProtect 进行身份验证。
- 通过 SAML IDP 成功验证后,用户将被重定向到空白页面。
Environment
- Palo Alto 防火墙
- 支持的 PAN OS 版本
- 启用登录前连接 (CBL) 的 GlobalProtect
- 最新的 Windows 10 和所有 Windows 11 客户端
Cause
- 在 IDP 页面上成功验证身份后,GlobalProtect 嵌入式浏览器遇到脚本错误
- 出现脚本错误的原因是, 互联网 Explorer 在 Windows 10 的更高版本和 Windows 11 的所有版本中已被弃用,这与计算机上 WebView2 运行时的安装相吻合。
- CBL 和 WebView2 不兼容。
- Error details are recorded in the GlobalProtect PanGPS.log:
Debug( 125): PanSAMLView: load request page. Debug( 342): PanSAMLView::OnBeforeNavigate2: https://secure.renown.org/saml20/idp/sso Error( 174): PanSAMLView: saml page is loaded Debug( 347): PanSAMLView::OnNavigateComplete2: https://secure.renown.org/signon/?flowId=03e510ba-9d4b-49ac-9999-052951757484 Debug( 51): PanSAMLView: script error happened Debug( 193): PanSamlDlg: display saml page to user
Resolution
- 旧版嵌入式 webview 支持 GlobalProtect 版本 6.2.2 及更低版本、6.1.4 及更低版本、6.0.9 及更低版本的带有 SAML 身份验证的 CBL。
- 较新的 webview2 不支持版本 6.2.3 及以上版本的带有 SAML 身份验证的 CBL。
- 该信息记录在登录前连接 SAML 身份验证中。