로그인 전 연결: SAML 인증으로 인해 빈 화면 발생

로그인 전 연결: SAML 인증으로 인해 빈 화면 발생

16125
Created On 04/29/24 11:22 AM - Last Modified 01/12/26 23:26 PM


Symptom


  • 고객이 로그온 전 연결(CBL)을 구성했습니다.
  • GlobalProtect에서 인증을 위해 SAML을 사용합니다.
  • SAML IDP를 통한 인증이 성공적으로 완료되면 사용자는 빈 페이지로 리디렉션됩니다.


Environment


  • 팔로 알토 방화벽
  • 지원되는 PAN-OS 버전
  • Connect Before Logon(CBL)이 활성화된 GlobalProtect
  • 최신 Windows 10 및 모든 Windows 11 클라이언트


Cause


  • IDP 페이지에서 인증에 성공한 후 GlobalProtect 내장 브라우저 스크립트 오류가 발생합니다.
  • 스크립트 오류는 Windows 10의 이후 버전과 모든 버전의 Windows 11에서 인터넷 Explorer가 더 이상 지원되지 않고, 해당 컴퓨터에 WebView2 Runtime이 설치됨에 따라 발생합니다.
  • CBL과 WebView2는 호환되지 않습니다.
  • Error details are recorded in the GlobalProtect PanGPS.log:
    Debug( 125): PanSAMLView: load request page.
    Debug( 342): PanSAMLView::OnBeforeNavigate2:  https://secure.renown.org/saml20/idp/sso
    Error( 174): PanSAMLView: saml page is loaded
    Debug( 347): PanSAMLView::OnNavigateComplete2: https://secure.renown.org/signon/?flowId=03e510ba-9d4b-49ac-9999-052951757484
    Debug(  51): PanSAMLView: script error happened
    Debug( 193): PanSamlDlg: display saml page to user


Resolution


  1. GlobalProtect 버전 6.2.2 및 이전 버전, 6.1.4 및 이전 버전, 6.0.9 및 이전 버전의 SAML 인증을 사용한 CBL은 이전의 내장형 웹 뷰에서 지원됩니다.
  2. 버전 6.2.3 이상의 SAML 인증을 사용한 CBL은 최신 Webview2에서 지원되지 않습니다.
  3. 해당 정보는 Connect before Logon SAML Authentication 에 기록되어 있습니다.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004OgUCAU&lang=ko&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language