Conectarse antes de iniciar sesión: la autenticación SAML genera una pantalla en blanco
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Created On 04/29/24 11:22 AM - Last Modified 10/23/25 00:10 AM
Symptom
- El cliente ha configurado Conectar antes de iniciar sesión (CBL).
- Uso de SAML para la autenticación con GlobalProtect.
- Después de una autenticación exitosa a través de SAML IDP, los usuarios son redirigidos a una página en blanco.
Environment
- Cortafuegos de Palo Alto
- Versiones de PAN-OS compatibles
- GlobalProtect con Conectar antes de iniciar sesión (CBL) habilitado
- Últimos clientes de Windows 10 y todos los de Windows 11
Cause
- Después de una autenticación exitosa en la página IDP, el explorador integrado de GlobalProtect encuentra un error de secuencia de comandos
- Los errores de script ocurren porque Internet Explorer está obsoleto en versiones posteriores de Windows 10 y todas las versiones de Windows 11, coincidiendo con la instalación de WebView2 Runtime en las máquinas.
- CBL y WebView2 son incompatibles.
- Error details are recorded in the GlobalProtect PanGPS.log:
Debug( 125): PanSAMLView: load request page. Debug( 342): PanSAMLView::OnBeforeNavigate2: https://secure.renown.org/saml20/idp/sso Error( 174): PanSAMLView: saml page is loaded Debug( 347): PanSAMLView::OnNavigateComplete2: https://secure.renown.org/signon/?flowId=03e510ba-9d4b-49ac-9999-052951757484 Debug( 51): PanSAMLView: script error happened Debug( 193): PanSamlDlg: display saml page to user
Resolution
- CBL con autenticación SAML para GlobalProtect versiones 6.2.2 y anteriores, 6.1.4 y anteriores, 6.0.9 y anteriores son compatibles con vistas web integradas más antiguas.
- CBL con autenticación SAML para las versiones 6.2.3 y superiores no son compatibles con la versión más reciente de webview2.
- La información está documentada en Conectarse antes de iniciar sesión Autenticación SAML .