Le client GlobalProtect ne parvient pas à se connecter au fournisseur d'identité (IdP) lors de l'utilisation du navigateur intégré pour SAML

Le client GlobalProtect ne parvient pas à se connecter au fournisseur d'identité (IdP) lors de l'utilisation du navigateur intégré pour SAML

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Created On 03/26/24 00:58 AM - Last Modified 01/29/25 03:49 AM


Symptom


  • Le client GlobalProtect est configuré pour s'authentifier à l'aide de SAML avec un navigateur intégré.
  • Le réseau local sur la machine cliente ne bloque rien, mais le GP ne parvient toujours pas à se connecter par intermittence.
  • L'échec se produit parce que le navigateur intégré ne peut pas atteindre le fournisseur d'identité SAML (IdP) et génère des erreurs de navigateur telles que « Impossible d'accéder à cette page » ou « Votre accès Internet est bloqué »
  • Le problème n'est pas observé si l' utilisateur passe à l'utilisation du navigateur par défaut pour SAML .
  • La connexion finit par fonctionner lorsque les utilisateurs continuent à réessayer plusieurs fois.
Error message

Error message 2


Environment


  • Application GlobalProtect (GP)
  • Authentification SAML avec navigateur intégré.
  • Version 6.0.8, 6.1.4, 6.2.2 ou inférieure.


Cause


Cela est dû à un problème connu avec le client pendant le flux de messages d’authentification SAML lors de l’utilisation de TLS1.3.


Resolution


  1. Le problème n'est pas observé lors de l'utilisation du navigateur par défaut pour SAML . Cela peut être considéré comme une solution alternative de contournement.
  2. Une autre solution alternative consiste à désactiver manuellement le TLS 1.3 sur la machine cliente. Contactez le fournisseur du système d'exploitation concerné pour savoir comment procéder.


Additional Information


  1. Le problème est résolu sous GPC-19745 à partir de la version client 6.0.10, 6.1.5, 6.2.3.
  2. La mise à niveau vers les versions fixes ultérieures résoudra le problème.


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