El cliente de GlobalProtect no puede conectarse al proveedor de identidad (IdP) cuando se utiliza el explorador integrado para SAML
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Created On 03/26/24 00:58 AM - Last Modified 01/29/25 03:49 AM
Symptom
- El cliente GlobalProtect está configurado para autenticarse usando SAML con el explorador integrado.
- La red local en la máquina cliente no bloquea nada, pero aún así el GP falla intermitentemente en conectarse.
- La falla ocurre porque el explorador integrado no puede acceder al proveedor de identidad SAML (IdP) y arroja errores de explorador como "No se puede acceder a esta página" o "su acceso a Internet está bloqueado".
- El problema no se observa si el usuario cambia para utilizar el explorador predeterminado para SAML .
- La conexión finalmente funciona cuando los usuarios intentan establecerla varias veces.
Environment
- Aplicación GlobalProtect (GP)
- Autenticación SAML con explorador integrado.
- Versión 6.0.8, 6.1.4, 6.2.2 o inferior.
Cause
Esto se debe a un problema conocido con el cliente durante el flujo de mensajes de autenticación SAML cuando se usa TLS1.3.
Resolution
- El problema no se observa cuando se utiliza el explorador predeterminado para SAML . Esto se puede considerar como una solución alternativa.
- Otra solución alternativa es desactivar manualmente TLS 1.3 en la máquina cliente. Comuníquese con el proveedor del sistema operativo correspondiente para identificar cómo hacerlo.
Additional Information
- El problema se solucionó en GPC-19745 a partir de las versiones del cliente 6.0.10, 6.1.5, 6.2.3.
- Actualizar a las versiones corregidas posteriores resolverá el problema.