No se puede escanear la imagen con Prisma Cloud el error "error al aumentar los datos: no se puede realizar el escaneo de imágenes para el contenedor que ejecutó chroot a otra carpeta" en Prisma Cloud
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Created On 05/05/22 09:21 AM - Last Modified 04/24/24 11:26 AM
Symptom
- No se puede escanear la imagen con Prisma Cloud el error "error al aumentar los datos: no se puede realizar el escaneo de imágenes para el contenedor que ejecutó chroot a otra carpeta" en Prisma Cloud
Environment
- Prisma Cloud
- CRI-O/entornos en contenedores
Cause
- Este problema chroot ocurre cuando este contenedor específico monta la raíz del sistema de archivos host (ver más abajo) y realiza chroot (cambió la raíz de su sistema de archivos).
{
"Source": "/",
"Destination": "/rootfs",
"Shared": false,
"Readonly": false
}
- En tales casos, no hay forma de escanear el sistema de archivos de imagen real, ya que básicamente aparece como si se estuviera ejecutando directamente en el host.
- Este mensaje de error se debe a una limitación en el escaneo de CRI-O imágenes por diseño.
- En CRI-Oentornos /containerd, las imágenes de los contenedores en ejecución se analizan buscando la raíz del contenedor a través de /proc/<container pid>/root.
- En los contenedores chrooted, /proc/<container pid>/root no apunta a la raíz original de la imagen, por lo que el escaneo sería parcial/incorrecto.
- En lugar de continuar con datos incorrectos, el Defensor emite este mensaje de error.
- Para obtener una visibilidad precisa de las vulnerabilidades que existen para esta imagen, el escaneo del registro proporcionaría resultados precisos.
Resolution
- Para escanear dichos contenedores, existe una solicitud de característica existente que se puede votar para su consideración futura: TP-I-1044.
Additional Information
- Para Docker no existe tal limitación, ya que Docker y CRI-O la implementación de escaneo de imágenes funcionan de manera diferente.
A. No se han visto casos similares para otras imágenes.
Q ¿Se encuentra este mensaje de error en los registros de la consola?
A. Esto se puede encontrar en los registros de Defender.
Q¿Hay alguna manera de determinar una lista establecida de imágenes que no se pueden escanear con el motivo en la consola UI y los registros?
A. No. Siempre que el Registro Público/Privado tenga asignados los permisos adecuados, Prisma Cloud los Defensores pueden escanear cualquier imagen.