AWS Cloud アカウントのステータスに「認証に失敗しました。 無効な外部IDまたPrisma Cloud信頼されたエンティティにアカウントが見つかりません」
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Created On 04/21/22 00:54 AM - Last Modified 10/23/23 13:02 PM
Symptom
AWS Cloud アカウントのステータスに「認証に失敗しました。 無効な外部IDまたPrisma Cloud信頼されたエンティティにアカウントが見つかりません」
Environment
- Prisma Cloud
- アマゾン ウェブ サービス (AWS)
- オンボーディング
- クラウド アカウント
Cause
このエラーはAWS ORGマスターまたはメンバーズ クラウド アカウントまたは単一のアカウントAWSクラウドアカウント。
次の理由により、エラーが発生する可能性があります。
- 無効な外部 ID
- Prisma Cloud 信頼されたエンティティにアカウントが見つかりません
- ロール名が無効です
- 無効な役割 ARN
Resolution
解決手順は、さまざまなクラウド セットアップ/環境向けです。 クラウド アカウント エラーに基づいて手順を実行します。つまり、クラウド ステータス エラーがAWS ORGマスター アカウントは、「クラウド アカウント エラーがオンにのみ表示される場合の解決手順」に従います。AWS ORGマスターアカウント」
- でのみクラウド アカウント エラーが表示される場合の解決手順AWS ORGマスターアカウント
- でのみクラウド アカウント エラーが表示される場合の解決手順AWS ORGメンバーのクラウド アカウント
- シングルでのみクラウド アカウント エラーが表示される場合の解決手順AWSクラウド アカウント
でのみクラウド アカウント エラーが表示される場合の解決手順AWS ORGマスターアカウント:
このエラーが表示される場合AWS ORGマスターアカウント、次の手順に従います。
- ログインAWSroot/管理アカウント
- に行くIAM> ロール > PrismaCloud のロールを選択
- 確実にAWSマスターの役割ARN入力したとおりに一致しています Prisma Cloud
- IAM > 役割 > PrismaCloud の役割を選択 > 信頼関係
- 確実にAWSマスター外部ID入力したとおりに一致しています Prisma Cloud
- 確実にPrisma Cloud信頼されたエンティティで見つかったアカウント
以下はその例ですPrisma Cloud信頼できるエンティティのアカウント
- AWSパブリック クラウド: 「arn:aws:iam::188619942792:ルート」
- AWSガバクラウド: 「arn:aws-us-gov:iam::342570144056:root」
- 中国AWS: "arn:aws-cn:iam::211784309483:ルート"
- のステップ 1 に従います。ドキュメント
上記のステップ 1 を実行した後
- に行くPrisma Cloudコンソール >設定>クラウド アカウント
- クリック編集クラウド アカウントの [アクション] の下にあるボタン
- 鉛筆ボタンをクリックして、クラウド アカウントの編集
- ステップの概要からステータスまでの完全な情報クラウド アカウントの編集ページ >終わり
- それでも同じエラーが表示される場合は、ステータスの更新に 24 時間かかる場合があります。
でのみクラウド アカウント エラーが表示される場合の解決手順AWS ORGメンバーのクラウド アカウント:
このエラーが表示される場合AWS ORGメンバーのアカウント、次の手順に従います。
- ログインAWSメンバーアカウント
- に行くIAM> ロール > PrismaCloud のロールを選択
- ロール名が入力したものと一致していることを確認してください Prisma Cloud
- IAM > 役割 > PrismaCloud の役割を選択 > 信頼関係
- 外部 ID が入力したとおりに一致していることを確認してください Prisma Cloud
- 確実にPrisma Cloud信頼されたエンティティで見つかったアカウント
以下はその例ですPrisma Cloud信頼できるエンティティのアカウント
- AWSパブリック クラウド: 「arn:aws:iam::188619942792:ルート」
- AWSガバクラウド: 「arn:aws-us-gov:iam::342570144056:ルート」
- 中国AWS: "arn:aws-cn:iam::211784309483:ルート"
- のステップ 2 に従います。ドキュメント
上記のステップ 2 を実行した後
- に行くPrisma Cloudコンソール >設定>クラウド アカウント
- クリック編集クラウド アカウントの [アクション] の下にあるボタン
- 鉛筆ボタンをクリックして、クラウド アカウントの編集
- ステップの概要からステータスまでの完全な情報クラウド アカウントの編集ページ >終わり
- それでも同じエラーが表示される場合は、ステータスの更新に 24 時間かかる場合があります。
シングルでのみクラウド アカウント エラーが表示される場合の解決手順AWSクラウド アカウント :
このエラーが表示される場合AWSアカウント、次の手順に従います。
- ログインAWSルートアカウント
- に行くIAM> ロール > PrismaCloud のロールを選択
- 役割を確認するARN入力したとおりに一致しています Prisma Cloud
- IAM > 役割 > PrismaCloud の役割を選択 > 信頼関係
- 外部を確認してくださいID入力したとおりに一致しています Prisma Cloud
- 確実にPrisma Cloud信頼されたエンティティで見つかったアカウント
以下はその例ですPrisma Cloud信頼できるエンティティのアカウント
- AWSパブリック クラウド: 「arn:aws:iam::188619942792:ルート」
- AWSガバクラウド: 「arn:aws-us-gov:iam::342570144056:ルート」
- 中国AWS: "arn:aws-cn:iam::211784309483:ルート"
- のステップ 1 ~ 4 に従います。ドキュメント
上記のステップ 1 ~ 4 を実行した後、
- に行くPrisma Cloudコンソール >設定>クラウド アカウント
- クリック編集クラウド アカウントの [アクション] の下にあるボタン
- 鉛筆ボタンをクリックして、クラウド アカウントの編集
- ステップの概要からステータスまでの完全な情報クラウド アカウントの編集ページ >終わり
- それでも同じエラーが表示される場合は、ステータスの更新に 24 時間かかる場合があります。