L’état du compte Aws Cloud affiche l’erreur « Échec de l’authentification. Externe ID non valide ou Prisma Cloud compte introuvable dans les entités approuvées »

L’état du compte Aws Cloud affiche l’erreur « Échec de l’authentification. Externe ID non valide ou Prisma Cloud compte introuvable dans les entités approuvées »

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Created On 04/21/22 00:54 AM - Last Modified 10/23/23 13:02 PM


Symptom


L’état du compte Aws Cloud affiche l’erreur « Échec de l’authentification. Externe ID non valide ou Prisma Cloud compte introuvable dans les entités approuvées »

Capture d’écran 2022-04-20 à 8.48.58 PM.png
 


Environment


  • Prisma Cloud
  • Services Web Amazon (Aws)
  • Onboarding
  • Comptes Cloud


Cause


Cette erreur peut apparaître sur les comptes Master ou Members Cloud ou sur AWS ORG un seul AWS compte Cloud.
La raison suivante peut provoquer l’erreur :
  1. Externe non valide ID
  2. Prisma Cloud compte introuvable dans Entités approuvées
  3. Nom de rôle non valide
  4. Rôle non valide ARN


Resolution


Les étapes de résolution sont pour différentes configurations/environnements Cloud. Suivez les étapes en fonction de l’erreur de votre compte cloud. c’est-à-dire si une erreur d’état du cloud apparaît sur le compte principal, suivez les « Étapes de résolution si l’erreur du compte cloud s’affiche uniquement sur AWS ORG AWS ORG le compte principal »

  • Étapes de résolution si l’erreur de compte cloud s’affiche uniquement sur AWS ORG le compte principal
  • Étapes de résolution si l'erreur de compte cloud s'affiche uniquement sur AWS ORG les comptes cloud des membres
  • Étapes de résolution si l’erreur de compte cloud s’affiche uniquement sur un compte cloud unique AWS


Étapes de résolution si l’erreur de compte cloud s’affiche uniquement sur AWS ORG le compte principal :

Si cette erreur apparaît sur AWS ORG le compte principal, procédez comme suit :

  1. Connectez-vous au AWS compte root/management
  2. Accédez à IAM > Rôles > Sélectionnez votre rôle pour PrismaCloud
  3. Assurez-vous que AWS le rôle ARN principal correspond à la date saisie Prisma Cloud
  4. IAM > Rôles > Sélectionnez votre rôle pour PrismaCloud > Relations d’approbation
  5. Assurez-vous que AWS Master External ID correspond à la correspondance telle qu’entrée Prisma Cloud
  6. Assurez-vous que Prisma Cloud le compte se trouve dans Entités approuvées
Voici l’exemple de Prisma Cloud Compte dans les entités approuvées
  • AWS Cloud public : « arn:aws:iam::188619942792:root »
  • AWS GovCloud:"arn:aws-us-gov:iam::342570144056: root »
  • Chine AWS: « arn:aws-cn:iam::211784309483:root »
Si vous trouvez des informations incorrectes, veuillez réexécuter CloudFormation > Stacks dans AWS le compte root/management
Après avoir suivi l’étape 1 ci-dessus
  1. Accédez aux paramètres de > de la console > aux Prisma Cloud comptes cloud
  2. Cliquez sur le bouton Modifier sous Action sur votre compte Cloud
Screen_Shot_2022-04-21_at_9_56_00_AM.jpg
  1. Cliquez sur le bouton Crayon pour modifier le compte cloud  Capture d’écran 2022-04-21 à 10.01.32 AM.png
  2. Informations complètes de l’étape Vue d’ensemble à l’état sur la page Modifier le compte cloud > terminé
  3. Si vous voyez toujours la même erreur, la mise à jour de l’état peut prendre 24 heures.


Étapes de résolution si l’erreur de compte cloud s’affiche uniquement le AWS ORG Comptes Cloud des membres

:Si cette erreur apparaît sur AWS ORG le compte du membre, procédez comme suit :
  1. Connectez-vous au AWS compte membre
  2. Accédez à IAM > Rôles > Sélectionnez votre rôle pour PrismaCloud
  3. Assurez-vous que le nom du rôle correspond à celui entré dans Prisma Cloud
  4. IAM > Rôles > Sélectionnez votre rôle pour PrismaCloud > Relations d’approbation
  5. Assurez-vous que l’ID externe correspond à la date saisie Prisma Cloud
  6. Assurez-vous que Prisma Cloud le compte se trouve dans Entités approuvées
Voici l’exemple de Prisma Cloud Compte dans les entités approuvées
  • AWS Cloud public : « arn:aws:iam::188619942792:root »
  • AWS GovCloud:"arn:aws-us-gov:iam::342570144056: root »
  • Chine AWS: « arn:aws-cn:iam::211784309483:root »
Si vous trouvez des informations incorrectes, veuillez réexécuter CloudFormation > StackSets dans AWS le compte root/management
Après avoir suivi l’étape 2 ci-dessus
  1. Accédez aux paramètres de > de la console > aux Prisma Cloud comptes cloud
  2. Cliquez sur le bouton Modifier sous Action sur votre compte Cloud
Screen_Shot_2022-04-21_at_9_56_00_AM.jpg
  1. Cliquez sur le bouton Crayon pour modifier le compte cloud  Capture d’écran 2022-04-21 à 10.01.32 AM.png
  2. Informations complètes de l’étape Vue d’ensemble à l’état sur la page Modifier le compte cloud > terminé
  3. Si vous voyez toujours la même erreur, la mise à jour de l’état peut prendre 24 heures.
     
 

Étapes de résolution si l’erreur de compte cloud ne s’affiche que sur un seul AWS compte cloud :

Si cette erreur apparaît sur AWS Compte, procédez comme suit :

  1. Connectez-vous au AWS compte racine
  2. Accédez à IAM > Rôles > Sélectionnez votre rôle pour PrismaCloud
  3. Assurez-vous que le rôle ARN correspond à la correspondance entre Prisma Cloud
  4. IAM > Rôles > Sélectionnez votre rôle pour PrismaCloud > Relations d’approbation
  5. Assurez-vous que External ID correspond à la correspondance telle qu’entrée dans Prisma Cloud
  6. Assurez-vous que Prisma Cloud le compte se trouve dans Entités approuvées
Voici l’exemple de Prisma Cloud Compte dans les entités approuvées
  • AWS Cloud public : « arn:aws:iam::188619942792:root »
  • AWS GovCloud:"arn:aws-us-gov:iam::342570144056: root »
  • Chine AWS: « arn:aws-cn:iam::211784309483:root »
Si vous trouvez des informations incorrectes, veuillez réexécuter CloudFormation > Stacks dans AWS le compte racine
Après avoir suivi les étapes 1 à 4 ci-dessus
  1. Accédez aux paramètres de > de la console > aux Prisma Cloud comptes cloud
  2. Cliquez sur le bouton Modifier sous Action sur votre compte Cloud
Screen_Shot_2022-04-21_at_9_56_00_AM.jpg
  1. Cliquez sur le bouton Crayon pour modifier le compte cloud  Capture d’écran 2022-04-21 à 10.01.32 AM.png
  2. Informations complètes de l’étape Vue d’ensemble à l’état sur la page Modifier le compte cloud > terminé
  3. Si vous voyez toujours la même erreur, la mise à jour de l’état peut prendre 24 heures.


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