El estado de la cuenta de AWS Cloud muestra el error "Error de autenticación. No se encuentra una cuenta externa ID o Prisma Cloud no válida en entidades de confianza"

El estado de la cuenta de AWS Cloud muestra el error "Error de autenticación. No se encuentra una cuenta externa ID o Prisma Cloud no válida en entidades de confianza"

11979
Created On 04/21/22 00:54 AM - Last Modified 10/23/23 13:02 PM


Symptom


El estado de la cuenta de AWS Cloud muestra el error "Error de autenticación. No se encuentra una cuenta externa ID o Prisma Cloud no válida en entidades de confianza"

Captura de pantalla 2022-04-20 a las 8.48.58 PM.png
 


Environment


  • Prisma Cloud
  • Servicios web de Amazon (AWS)
  • Incorporación
  • Cuentas en la nube


Cause


Este error puede aparecer en las cuentas Master o Members Cloud o en una sola AWS cuenta en AWS ORG la nube.
La siguiente razón puede causar el error:
  1. Externo no válido ID
  2. Prisma Cloud cuenta no encontrada en entidades de confianza
  3. Nombre de rol no válido
  4. Rol no válido ARN


Resolution


Los pasos de resolución son para diferentes configuraciones / entornos de nube. Siga los pasos según el error de su cuenta de Cloud. es decir, si aparece un error de estado de nube en la cuenta maestra, siga "Pasos de resolución si el error de la cuenta en la nube solo se muestra en la AWS ORG AWS ORG cuenta maestra"

  • Pasos de resolución si el error de la cuenta en la nube solo se muestra en la AWS ORG cuenta maestra
  • Pasos de resolución si el error de la cuenta en la nube solo se muestra en las cuentas en AWS ORG la nube de los miembros
  • Pasos de resolución si el error de la cuenta en la nube solo se muestra en una AWS sola cuenta en la nube


Pasos de resolución si el error de la cuenta en la nube solo se muestra en la AWS ORG cuenta maestra:

Si aparece este error en la AWS ORG cuenta maestra, siga los pasos a continuación:

  1. Inicie sesión en la AWS cuenta raíz / administración
  2. Vaya a IAM > roles > Seleccione su rol para PrismaCloud
  3. Asegúrese de que AWS el rol maestro coincida con el ARN especificado en Prisma Cloud
  4. IAM > Roles > Seleccione su rol para las relaciones de PrismaCloud > Trust
  5. Asegúrese de que AWS Master External ID coincida con lo especificado en Prisma Cloud
  6. Asegúrate de que la cuenta se encuentre en Entidades de Prisma Cloud confianza
A continuación se muestra el ejemplo de Cuenta en entidades de Prisma Cloud confianza
  • AWS Nube pública: "arn:aws:iam::188619942792:root"
  • AWS GovCloud:"arn:aws-us-gov:iam::342570144056: root"
  • China AWS: "arn:aws-cn:iam::211784309483:root"
Si encuentra información incorrecta, vuelva a ejecutar CloudFormation > Stacks en AWS la cuenta raíz/administración
Después de seguir el paso 1 anterior
  1. Ve a Prisma Cloud Configuración de la consola > > Cuentas en la nube
  2. Haga clic en el botón Editar en Acción en su cuenta en la nube
Screen_Shot_2022-04-21_at_9_56_00_AM.jpg
  1. Haga clic en el botón Lápiz para editar la cuenta en la nube  Captura de pantalla 2022-04-21 a las 10.01.32 AM.png
  2. Información completa desde el paso Descripción general hasta el estado en la página Editar cuenta de Cloud > Hecho
  3. Si sigue viendo el mismo error, puede tardar 24 horas en actualizar el estado.


Pasos de resolución si el error de la cuenta en la nube solo se muestra en AWS ORG Cuentas en la nube

del miembro: si aparece este error en AWS ORG la cuenta del miembro, siga los pasos a continuación:
  1. Inicie sesión en la cuenta de AWS miembro
  2. Vaya a IAM > roles > Seleccione su rol para PrismaCloud
  3. Asegúrese de que el nombre del rol coincida con el especificado en Prisma Cloud
  4. IAM > Roles > Seleccione su rol para las relaciones de PrismaCloud > Trust
  5. Asegúrese de que el ID externo coincida con el introducido en Prisma Cloud
  6. Asegúrate de que la cuenta se encuentre en Entidades de Prisma Cloud confianza
A continuación se muestra el ejemplo de Cuenta en entidades de Prisma Cloud confianza
  • AWS Nube pública: "arn:aws:iam::188619942792:root"
  • AWS GovCloud:"arn:aws-us-gov:iam::342570144056: root"
  • China AWS: "arn:aws-cn:iam::211784309483:root"
Si encuentra información incorrecta, vuelva a ejecutar CloudFormation > StackSets en AWS la cuenta raíz/administración
Después de seguir el paso 2 anterior
  1. Ve a Prisma Cloud Configuración de la consola > > Cuentas en la nube
  2. Haga clic en el botón Editar en Acción en su cuenta en la nube
Screen_Shot_2022-04-21_at_9_56_00_AM.jpg
  1. Haga clic en el botón Lápiz para editar la cuenta en la nube  Captura de pantalla 2022-04-21 a las 10.01.32 AM.png
  2. Información completa desde el paso Descripción general hasta el estado en la página Editar cuenta de Cloud > Hecho
  3. Si sigue viendo el mismo error, puede tardar 24 horas en actualizar el estado.
     
 

Pasos de resolución si el error de la cuenta en la nube se muestra solo en una cuenta única AWS en la nube:

Si este error aparece en AWS Cuenta, siga los pasos a continuación:

  1. Inicie sesión en la AWS cuenta raíz
  2. Vaya a IAM > roles > Seleccione su rol para PrismaCloud
  3. Asegúrese de que el rol ARN coincida con lo especificado en Prisma Cloud
  4. IAM > Roles > Seleccione su rol para las relaciones de PrismaCloud > Trust
  5. Asegúrese de que Externo ID coincida con lo especificado en Prisma Cloud
  6. Asegúrate de que la cuenta se encuentre en Entidades de Prisma Cloud confianza
A continuación se muestra el ejemplo de Cuenta en entidades de Prisma Cloud confianza
  • AWS Nube pública: "arn:aws:iam::188619942792:root"
  • AWS GovCloud:"arn:aws-us-gov:iam::342570144056: root"
  • China AWS: "arn:aws-cn:iam::211784309483:root"
Si encuentra información incorrecta, vuelva a ejecutar CloudFormation > Stacks en AWS la cuenta raíz
Después de seguir los pasos anteriores 1 a 4
  1. Ve a Prisma Cloud Configuración de la consola > > Cuentas en la nube
  2. Haga clic en el botón Editar en Acción en su cuenta en la nube
Screen_Shot_2022-04-21_at_9_56_00_AM.jpg
  1. Haga clic en el botón Lápiz para editar la cuenta en la nube  Captura de pantalla 2022-04-21 a las 10.01.32 AM.png
  2. Información completa desde el paso Descripción general hasta el estado en la página Editar cuenta de Cloud > Hecho
  3. Si sigue viendo el mismo error, puede tardar 24 horas en actualizar el estado.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004OD3CAM&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language