Error message connecting to GlobalProtect "The network connection is unreachable or the portal is unresponsive. Check the network connection and reconnect"
156968
Created On 04/19/22 18:58 PM - Last Modified 04/23/24 03:51 AM
Symptom
- GlobalProtect agent fails to connect to portal even though PC is able to resolve the correct IP for the portal
- Using the browser, the portal can be reached and agent can be downloaded.
- The following error message is seen on the GlobalProtect agent
The network connection is unreachable or the portal is unresponsive.
Check the network connection and reconnect.Environment
- PAN-OS 10.1.4
- PA-3220
- GLobalProtect version 5.2.10
- Use of passcode to disable Global Protect
Cause
- When GlobalProtect APP is customized using step 8 of Customize GP APP for users to disable the app with passcode, the passcode is set to use one or both of angled backets ( "<" or ">" characters)
- Global Protect agent treats everything with Less-than sign and/or Greater-than sign as an open XML tag,
- This causes XML parsing error
- This is seen in the GlobalProtect agent logs
04/01/22 03:47:21:932 end tag </u</passcode> not found
04/01/22 03:47:21:932 end tag </passcode> not found
04/01/22 03:47:21:932 end tag </agent-ui> not found
04/01/22 03:47:21:932 Failed to parse portal config: <?xml version="1.0" encoding="UTF-8" ?>
Note: An example of such password is "X?2939<u"
Resolution
- Change the password set (Step 8 of Customize GP APP ) as to not use the angle brackets "<" or ">"
- This should resolve the issue.
Additional Information
Here is an general example of such xml parsing error
<agent-ui>
<can-save-password>yes</can-save-password>
<passcode>R?2939<u</passcode>