GlobalProtect: Windows Security authentication pop-up for PanGPA.exe when connecting to GlobalProtect Portal/Gateway
7599
Created On 04/14/22 08:13 AM - Last Modified 03/04/23 02:01 AM
Symptom
- User get a Windows Security prompt showing PanGPA.exe needs authentication when connecting to GlobalProtect Portal/Gateway
- PanGPA.log shows the message "Wait too long in connecting, display still working..."
(P7560-T2392)Debug( 325): 03/03/22 15:34:46:708 CPanSAMLView::OnDocumentComplete - a html page pop up, potential the SAML authentication login page
(P7560-T2392)Debug( 688): 03/03/22 15:34:47:020 Receive inactive message.
(P7560-T2392)Debug( 482): 03/03/22 15:34:50:088 CPanSAMLDlg::HideViewImpl - view is visible now.
(P7560-T2392)Debug(1416): 03/03/22 15:34:53:220 Wait too long in connecting, display still working...
Environment
- GlobalProtect App authentication using Azure SAML
- PAN-OS firewall configured with GlobalProtect Portal/Gateway
- Windows OS
Cause
- Windows firewall in the user machine was blocking connections from the GlobalProtect PanGPA process
Resolution
- Allow the PanGPA.exe in the Windows firewall