The GlobalProtect OTP requested by Panorama is not accepted for Cloud Services Account verification
473
Created On 04/06/22 15:29 PM - Last Modified 10/28/25 03:36 AM
Symptom
- Panorama prompts for a GlobalProtect OTP.
- The correct OTP used under Panorama > Cloud Services > Configuration > Verify Account,
- Error message "Failed to verify account. Failed to complete feature/license checks" is displayed.
Environment
- Palo Alto Firewall or Panorama.
- Supported PAN-OS
Cause
Multiple GlobalProtect Licenses are installed on the Device.
Resolution
- Remove the license files on the Panorama using "delete license key <license key>
- Retrieve license keys from the server In Panorama under GUI: Panorama > Licenses > Retrieve license keys from license server
- Check the license again and verify only one GlobalProtect cloud Service is displayed.
- Re-verify using the OTP again for successful verification
- An example is given under "Additional Information" section below.
Additional Information
- On Panorama CLI, we see multiple entries for GlobalProtect Cloud Service -
> delete license key ?
Device_Management_License_2020_04_02_I9139406.key 2020/05/06 14:55:31 0.3K
GlobalProtect_Cloud_Service_for_Mobile_Users_2020_03_12.key 2020/05/06 14:55:31 0.3K <<<<<<<<<<<<<<<<
GlobalProtect_Cloud_Service_for_Mobile_Users_2020_06_09.key 2020/06/11 12:13:43 0.3K <<<<<<<<<<<<<<<<
Logging_Service_2020_06_09.key 2020/06/11 12:13:43 0.3K
Premium_F5599052.key 2020/05/06 14:55:31 0.3K
Device_Management_License_2020_04_02_I9139406.key 2020/05/06 14:55:31 0.3K
GlobalProtect_Cloud_Service_for_Mobile_Users_2020_03_12.key 2020/05/06 14:55:31 0.3K <<<<<<<<<<<<<<<<
GlobalProtect_Cloud_Service_for_Mobile_Users_2020_06_09.key 2020/06/11 12:13:43 0.3K <<<<<<<<<<<<<<<<
Logging_Service_2020_06_09.key 2020/06/11 12:13:43 0.3K
Premium_F5599052.key 2020/05/06 14:55:31 0.3K
<2. Delete all license keys for GP Cloud Service and Logging service (except Device Management and Premium keys) using -
> delete license key <key name>
delete license key GlobalProtect_Cloud_Service_for_Mobile_Users_2020_06_09.key
successfully removed Logging_Service_2020_03_12.key
> delete license key GlobalProtect_Cloud_Service_for_Mobile_Users_2020_03_12.key
successfully removed Logging_Service_2020_03_12.key
> delete license key Logging_Service_2020_03_12.key
successfully removed Logging_Service_2020_03_12.key
successfully removed Logging_Service_2020_03_12.key
> delete license key GlobalProtect_Cloud_Service_for_Mobile_Users_2020_03_12.key
successfully removed Logging_Service_2020_03_12.key
> delete license key Logging_Service_2020_03_12.key
successfully removed Logging_Service_2020_03_12.key
3. In Panorama, Panorama > Licenses > Retrieve license keys from license server to fetch the licenses from license server
4. In the CLI, we can now see only 1 license key for GP Cloud Service -
> delete license key ?
Device_Management_License_2020_06_05_I1131298.key 2020/06/11 13:25:17 0.3K
GlobalProtect_Cloud_Service_for_Mobile_Users_2020_06_09.key 2020/06/11 13:25:17 0.3K <<<<<<<<<<<<<<<<
Logging_Service_2020_06_09.key 2020/06/11 13:25:17 0.3K
Premium_97063003.key 2020/06/11 13:25:17 0.3K
> delete license key ?
Device_Management_License_2020_06_05_I1131298.key 2020/06/11 13:25:17 0.3K
GlobalProtect_Cloud_Service_for_Mobile_Users_2020_06_09.key 2020/06/11 13:25:17 0.3K <<<<<<<<<<<<<<<<
Logging_Service_2020_06_09.key 2020/06/11 13:25:17 0.3K
Premium_97063003.key 2020/06/11 13:25:17 0.3K
5. Verify the account with OTP again and will be was successfull.