Cannot connect to Email server configured under Server Profile after upgrade to 10.0.4
10130
Created On 01/27/22 17:30 PM - Last Modified 10/20/22 00:37 AM
Symptom
- Unable to connect firewall to smtp server.
Environment
- service route for smtp is via mgmt interface
- proxy server is configured under service route
- Upgraded Firewall from PAN-OS 10.0.1 to 10.0.4
Cause
Change in the behavior starting 10.0 OS version, proxy support for smtp feature was introduced that means if you configure a proxy server under Device-> Setup-> Services -> proxy server the FW connection to the email server will go through the proxy server.
Resolution
Upgrade to 10.0.8 and 10.1.5 and onward to have the option to enable or disable this behavior with the software fix PAN-168890
With this fix:
- SNMP won't connect to proxy by default.
- To enable proxy for SNMP you have to issue the command:
debug use-proxy-for-email-server <disabled|enabled|show>
Additional Information
PAN-168890 A CLI command was added to address an issue where a configured proxy server for a service route was automatically applied to the email server service route.