HIP Error de comprobación personalizada para Windows 11
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Created On 01/22/22 22:53 PM - Last Modified 09/05/23 18:51 PM
Symptom
- Dado que Windows 11 es una versión recién lanzada OS , la opción para seleccionar Windows 11 no está disponible actualmente en el menú desplegable Host para un HIP objeto (en Objetos > GlobalProtect > HIP objetos).
- A La configuración personalizada de comprobación de HIP Windows 11 se configura de la siguiente manera:
- Clave del Registro: Computer\HKEY_LOCAL_MACHINE\\Microsoft\Windows NT\SOFTWARECurrentVersion
- Clave: ProductName
- Valor: Windows 11 Pro
- En Objetos > > objetos > <su HIP objeto> > GlobalProtect HIP comprobaciones personalizadas
- En Network > Global Protect > Portals > <su portal> > agente > <su agente> > recopilación de datos > HIP comprobaciones personalizadas
- HIP Se produce un error en la comprobación personalizada para Windows 11.Mirando la HIP información, vemos grandes 'Xs al lado de las comprobaciones del registro
Environment
- Palo Alto Firewall
- HIP Objeto configurado
- Clientes de Windows 11
Cause
- PanGpHip.log (de los GP registros de depuración de clientes) muestra lo siguiente:
(P2920-T23136)Debug( 105): 10/25/21 14:41:05:956 User profile directory is C:\Users\testUser (P2920-T23136)Debug( 167): 10/25/21 14:41:05:957 profileInfo username testUser, profile path (null), server (null) (P2920-T23136)Error( 101): 10/25/21 14:41:05:964 CheckRegistryKey(): unknown registry root Computer. (P2920-T23136)Debug( 50): 10/25/21 14:41:05:964 HipCustomCheck(): check registry key failed. Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion <<<<<<<<<<<< (P2920-T23136)Debug( 736): 10/25/21 14:41:05:967 Check antimalware category V4... (P2920-T23136)Debug(1522): 10/25/21 14:41:06:479 GetProductHipInfo for product: CrowdStrike Falcon (6.28.14210.0), vendor: CrowdStrike, Inc., signature: 2866 (P2920-T23136)Debug(1881): 10/25/21 14:41:06:768 Opswat Error(-11): An error when a method call was made on a component that does not support it., Method: WAAPI_MID_GET_LAST_SCAN_TIME, Signature: 2866, Category: 5(ANTIMALWARE), OESIS (V4 ver: 4.3.2290.0) (P2920-T23136)Debug(1430): 10/25/21 14:41:06:768 >>> GetAntimalwareProductInfo for "CrowdStrike Falcon" took 288 ms (P2920-T23136)Debug(1529): 10/25/21 14:41:06:768 >>> Check product "CrowdStrike Falcon" took 293 ms (P2920-T23136)Debug(1522): 10/25/21 14:41:09:925 GetProductHipInfo for product: Windows Defender (4.18.2105.5), vendor: Microsoft Corporation, signature: 477 (P2920-T23136)Debug(1881): 10/25/21 14:41:09:927 Opswat Error(-23): An error when the system or product is in an invalid state to perform the invocation call requested., Method: WAAPI_MID_GET_RTP_STATE, Signature: 477, Category: 5(ANTIMALWARE), OESIS (V4 ver: 4.3.2290.0)
- El registro indica que la clave del Registro se configuró como "Equipo\HKEY_LOCAL_MACHINE\\Microsoft\Windows NT\SOFTWARECurrentVersion"
Resolution
- La clave del Registro se configuró como "Computer\HKEY_LOCAL_MACHINE\\Microsoft\Windows NT\SOFTWARECurrentVersion", como se ve en los registros de PanGPHip. Elimine la palabra "Equipo" en la cadena anterior para que esto sea "HKEY_LOCAL_MACHINE\\Microsoft\WindowsNT\SOFTWARECurrentVersion"
- Confirme el cambio y el problema ahora debería resolverse