HIP Custom Check fails for Windows 11

HIP Custom Check fails for Windows 11

13113
Created On 01/22/22 22:53 PM - Last Modified 09/05/23 18:51 PM


Symptom


  • Since Windows 11 is a newly released OS version, the option for selecting Windows 11 is not available at present in the Host dropdown for a HIP Object (under Objects > GlobalProtect > HIP Objects).
NoWindows11OptionHIPObject.png 
  • A custom Windows 11 check HIP configuration is setup as below:
  • Registry Key: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
  • Key: ProductName
  • Value: Windows 11 Pro
  • Under Objects > GlobalProtect > HIP Objects > <your HIP Object> > Custom Checks
PA-HIP-Custom-Check-registry-2.png
  • Under Network > Global Protect > Portals > <your portal> > Agent > <your agent> > HIP Data Collection > Custom Checks
PA-HIP-Custom-Check-registry1.png
 
  • HIP Custom Check fails for Windows 11. Looking at HIP information, we see big 'X's beside the registry checks
PA-HIP-Custom-Check-registry.png


Environment


  • Palo Alto Firewall
  • HIP Object configured
  • Windows 11 clients


Cause


  • ​​​​​​PanGpHip.log (from the GP Client Debug logs) shows the following:
(P2920-T23136)Debug( 105): 10/25/21 14:41:05:956 User profile directory is C:\Users\testUser
(P2920-T23136)Debug( 167): 10/25/21 14:41:05:957 profileInfo username testUser, profile path (null), server (null)
(P2920-T23136)Error( 101): 10/25/21 14:41:05:964 CheckRegistryKey(): unknown registry root Computer.
(P2920-T23136)Debug( 50): 10/25/21 14:41:05:964 HipCustomCheck(): check registry key failed. Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion <<<<<<<<<<<<
(P2920-T23136)Debug( 736): 10/25/21 14:41:05:967 Check antimalware category V4...
(P2920-T23136)Debug(1522): 10/25/21 14:41:06:479 GetProductHipInfo for product: CrowdStrike Falcon (6.28.14210.0), vendor: CrowdStrike, Inc., signature: 2866
(P2920-T23136)Debug(1881): 10/25/21 14:41:06:768 Opswat Error(-11): An error when a method call was made on a component that does not support it., Method: WAAPI_MID_GET_LAST_SCAN_TIME, Signature: 2866, Category: 5(ANTIMALWARE), OESIS (V4 ver: 4.3.2290.0)
(P2920-T23136)Debug(1430): 10/25/21 14:41:06:768 >>> GetAntimalwareProductInfo for "CrowdStrike Falcon" took 288 ms
(P2920-T23136)Debug(1529): 10/25/21 14:41:06:768 >>> Check product "CrowdStrike Falcon" took 293 ms
(P2920-T23136)Debug(1522): 10/25/21 14:41:09:925 GetProductHipInfo for product: Windows Defender (4.18.2105.5), vendor: Microsoft Corporation, signature: 477
(P2920-T23136)Debug(1881): 10/25/21 14:41:09:927 Opswat Error(-23): An error when the system or product is in an invalid state to perform the invocation call requested., Method: WAAPI_MID_GET_RTP_STATE, Signature: 477, Category: 5(ANTIMALWARE), OESIS (V4 ver: 4.3.2290.0)
  • ​The log indicates that the registry key was configured as "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion"


Resolution


As seen in the PanGPHip logsThe registry key was configured as
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion.
  1. Delete the word "Computer" in the above string to make this HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
  2. Commit the change and the issue should now be resolved


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004MwuCAE&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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