Error: "Failed to verify account. Failed to complete feature/license check" due to Expired Panorama Certificate

Error: "Failed to verify account. Failed to complete feature/license check" due to Expired Panorama Certificate

32925
Created On 01/19/22 03:03 AM - Last Modified 02/14/23 22:54 PM


Symptom


  • Panorama has all the valid licenses present but account verification is still getting failed with the error "Failed to verify account. Failed to complete feature/license check".
  • No old expired licenses are present on the Panorama.
  • Able to fetch the licenses from the update server.

 



Environment


  • Prisma Access (Panorama Managed)
  • Plugins
  • PAN-OS 9.1,10.0,10.1
  • Administration, Licensing


Cause


An error "Failed to verify account. Failed to complete feature/license check" will be seen if Panorama Certificate has been expired when checked through the CLI.

 



Resolution


Steps to follow:
  1. Access the Panorama via CLI.
  2. Run the below command to check the Panorama certificate expiration.
show plugins cloud_services panorama-certificate status
  1. If the Panorama-Certificate has been expired, delete the existing expired certificate using the below command.
request plugins cloud_services panorama-certificate delete
  1. Verify and fetch the license capabilities. 
debug plugins cloud_services prisma-access license-capabilities show
debug plugins cloud_services prisma-access license-capabilities fetch
  1. Fetch the certificate again and we should be able to verify the account successfully.
request plugins cloud_services panorama-certificate fetch otp <OTP_KEY_FROM_SUPPORT_PORTAL>

 




 


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004MsOCAU&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language