Unable to auto-upgrade Defender from the Prisma Cloud Compute Console UI
7964
Created On 12/05/21 06:21 AM - Last Modified 12/22/21 03:13 AM
Symptom
- Unable to auto-upgrade Defender from the Prisma Cloud Compute Console UI
Environment
- Prisma Cloud Compute
- Version 21.08
Cause
- Starting with version 21.08, support for Defender versions has been extended to n-2.
- This implies that Defenders can now be up to two versions (21.08 and 21.04) behind the Console and still provide protection and visibility for your workloads.
- With this new support for backwards compatibility, auto-upgrade has been deprecated.
- Upgrade action from the Console UI for Orchestrated Defenders is deprecated, since we are removing auto-upgrade.
- Upgrade action from the Console UI is still supported for Single Defenders.
- For more details, refer the 21.08 Release Notes : 21.08 Release Notes
Resolution
- Defenders can be manually upgraded : Manually upgrade Defender DaemonSets
Additional Information
- This compatibility is automatically enabled and you don’t need to configure it.