当 macOS 端点从 Catalina 升级到 Big Sur 后,用户可能无法访问为应用程序/域拆分隧道配置的某些应用程序GlobalProtectApp从 5.2.6 升级到 5.2.8 或 5.2.9。

当 macOS 端点从 Catalina 升级到 Big Sur 后,用户可能无法访问为应用程序/域拆分隧道配置的某些应用程序GlobalProtectApp从 5.2.6 升级到 5.2.8 或 5.2.9。

11561
Created On 12/01/21 05:54 AM - Last Modified 05/17/23 03:22 AM


Symptom


当 macOS 端点从 Catalina 升级到 Big Sur 后,用户可能无法访问为应用程序/域拆分隧道配置的某些应用程序GlobalProtectApp从 5.2.6 升级到 5.2.8 或 5.2.9。 如果GlobalProtectApp被禁用,用户可以毫无问题地打开相同的应用程序。

Environment


将 macOS 端点从 Catalina 升级到 Big Sur,然后是GlobalProtectApp从 5.2.6 升级到 5.2.8 或 5.2.9。
为受影响的应用程序配置了排除拆分隧道应用程序/域。
macOS 10.15.4 及更高版本
GlobalProtectApp5.1.4 及以上。


 


Cause


当 macOS 端点从 Catalina 升级到 Big Sur 后跟GlobalProtectApp从 5.2.6 升级到 5.2.8 或 5.2.9,系统扩展有时可能不会自动启用。 您可以通过从 Mac 终端发出命令“$ systemextensionsctl list”来验证系统扩展是否已启用。 您还可以转到“系统偏好设置”->“网络”来验证系统扩展是否已启用。

全球保护行动: 域拆分隧道
GlobalProtectAp :App分裂隧道
GlobalProtectEn : 执法者
GlobalProtectDn : 分裂DNS

如果未启用系统扩展,用户可能无法访问为应用程序/域拆分隧道配置的应用程序。 例如,如果 Zoom 应用程序流量配置为在GlobalProtect网关,您可能看不到 Zoom 流量被排除在外GlobalProtect隧道。 因此,用户可能无法访问 Zoom 应用程序。 您可以通过在 macOS 端点的物理适配器上执行数据包捕获来验证流量是否已成功从隧道中排除。 如果你也没有看到DNS或者TCP/UDP数据包捕获中受影响的应用程序的数据包,这表明拆分隧道未按预期工作。



Resolution


要解决此问题,您可以使用以下解决方法:

  • 重新启动 macOS 端点以重新启用系统/网络扩展。

(自从GlobalProtectApp有NO控制系统/网络扩展SDKmacOS 端点上使用的框架,Palo Alto Networks 将无法通过更改代码来解决此问题GlobalProtectApp. 我们已向 Apple (FB974069) 提交反馈案例,以跟踪 Apple 系统/网络扩展的此限制SDK框架)。

如果上述解决方法无法解决问题,请收集以下日志并创建支持案例。

  1. 收集GlobalProtect通过启用日志DUMP级别日志记录。
  2. 使用命令收集数据包捕获“ sudo tcpdump -i all -kINP -w gptest.pcapng ”。
  3. 从 Mac 终端收集输出“$ systemextensionsctl list”。

 

 



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004MSkCAM&lang=zh_CN&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language