を回避する方法RQLの [調査] タブのクエリ タイムアウトPrisma Cloud?
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Created On 11/09/21 04:09 AM - Last Modified 12/20/23 18:12 PM
Objective
- を回避する方法RQLの [調査] タブのクエリ タイムアウトPrisma Cloud?
Environment
Prisma Cloud
Procedure
を実行するときRQL[調査] タブでクエリを実行すると、次のメッセージ "No Results Available" が表示される場合があります。 これは、次のシナリオで発生します:-
- クエリに一致する、オンボーディングされたクラウド アカウントで使用できるリソースがありません。
- のRQLクエリがタイムアウトしました。
上記のシナリオを確認するには、次の例を検討してください。
- のRQLクエリ 1 では、このクエリに一致するクラウド リソースが利用できないことを示す "No Results Available" メッセージのみが表示されます。
- ただし、RQLクエリ 2 では、"No Results Available" メッセージとともに、クエリの下に "Searches" に関連する 3 つのタブも表示されます。RQLクエリのタイムアウト。
RQLクエリ 2 : を使用している「すべてのオンボード クラウド アカウント」で実行中のすべてのインスタンスを特定します。AMI管理アカウントが所有していません。
原因
- を実行するときRQL調査タブでクエリを実行すると、バックエンドはデータベースにクエリを実行して、入力したフィルターに一致する参照を探します。
- のRQLクエリ 2 では、バックエンドがクエリに一致するすべてのオンボード クラウド アカウントのリソースについてデータベースにクエリを実行しました。
- リソースが多すぎて 3 分で整理できない状況では、RQL上記の例に見られるように、クエリはタイムアウトする場合があります。
回避策
- 避けるためにRQLクエリをタイムアウトさせ、それをフィルタリングしてより小さなセグメント、つまり特定のアカウントまたはアカウント グループのいずれかをスキャンします。
- 次の例では、cloud.account = 'RDS AWS Test' が追加され、RQL特定のアカウントへのクエリ。