Comment éviter un délai d’expiration RQL de requête dans l’onglet Enquêter dans Prisma Cloud?
5475
Created On 11/09/21 04:09 AM - Last Modified 12/20/23 18:12 PM
Objective
- Comment éviter un délai d’expiration RQL de requête dans l’onglet Enquêter dans Prisma Cloud?
Environment
Prisma Cloud
Procedure
Lors de l’exécution d’une requête dans l’onglet RQL Enquêter, le message suivant « Aucun résultat disponible » peut s’afficher. Cela se produit dans les scénarios suivants: -
- Aucune ressource disponible dans les comptes cloud intégrés pour correspondre à la requête.
- La RQL requête a expiré.
Pour confirmer les scénarios ci-dessus, considérez les exemples suivants.
- Dans RQL la requête 1, nous voyons uniquement le message « Aucun résultat disponible » qui indique qu’aucune ressource cloud n’est disponible pour correspondre à cette requête.
- Cependant, dans RQL la requête 2, avec le message « Aucun résultat disponible », nous voyons également les 3 onglets relatifs aux « Recherches » sous la requête, qui indiquent un RQL délai d’expiration de la requête.
RQL Requête 2 : Identifiez toutes les instances en cours d’exécution dans « tous les comptes cloud intégrés » qui utilisent un AMI compte non géré détenu.
Cause
- Lors de l’exécution d’une requête dans l’onglet RQL Investigation, le backend interroge la base de données pour les références qui correspondent au filtre que nous entrons.
- Dans RQL la requête 2, le backend a interrogé la base de données pour obtenir des ressources dans tous les comptes cloud intégrés correspondant à la requête.
- Dans les situations où il y a trop de ressources à trier en 3 minutes, la RQL requête peut expirer, comme indiqué dans l’exemple ci-dessus.
Contournement
- Pour éviter RQL l’expiration de la requête, filtrez-la pour analyser un segment plus petit, c’est-à-dire un compte ou un groupe de comptes particulier.
- Dans l'exemple suivant, cloud.account = ' Test'RDS AWS est ajouté pour filtrer la RQL requête vers un compte particulier.