Error:
An unexpected error occurred. Please click Reload to try again.
Error:
An unexpected error occurred. Please click Reload to try again.
¿Cómo evitar un RQL tiempo de espera de consulta en la pestaña ... - Knowledge Base - Palo Alto Networks

¿Cómo evitar un RQL tiempo de espera de consulta en la pestaña Investigar en Prisma Cloud?

5481
Created On 11/09/21 04:09 AM - Last Modified 12/20/23 18:12 PM


Objective


  • ¿Cómo evitar un RQL tiempo de espera de consulta en la pestaña Investigar en Prisma Cloud?


Environment


  • Prisma Cloud



Procedure


Al ejecutar una RQL consulta en la ficha Investigar, puede aparecer el siguiente mensaje "No hay resultados disponibles". Esto ocurre durante los siguientes escenarios:
  1. No hay recursos disponibles en las cuentas en la nube incorporadas para que coincidan con la consulta.
  2. Se agotó el tiempo de espera de la RQL consulta.

Para confirmar los escenarios anteriores, considere los siguientes ejemplos.

  • En RQL la consulta 1, solo vemos el mensaje "No hay resultados disponibles" que indica que no hay recursos en la nube disponibles para que coincidan con esta consulta.
  • Sin embargo, en RQL la consulta 2, con el mensaje "No hay resultados disponibles" también vemos las 3 pestañas pertenecientes a "Búsquedas" debajo de la consulta, que indican un RQL tiempo de espera de consulta.
RQL Consulta 1 : Identifique todas las instancias en ejecución en una "cuenta en la nube incorporada en particular" que utilizan una AMI cuenta que no es propiedad de la cuenta administrada.

Imagen de usuario añadido

RQL Consulta 2
: Identifique todas las instancias en ejecución en "todas las cuentas en la nube incorporadas" que utilizan cuentas administradas que AMI no son propiedad de ellas.

Imagen de usuario añadido

Causa

  • Al ejecutar una RQL consulta en la pestaña Investigar, el backend consultará la base de datos en busca de referencias que coincidan con el filtro que ingresamos.
  • En RQL la consulta 2, el back-end consultó la base de datos en busca de recursos en todas las cuentas en la nube incorporadas que coincidieran con la consulta.
  • En situaciones en las que hay demasiados recursos para ordenar en 3 minutos, la consulta puede agotar el tiempo de espera, como se ve en el RQL ejemplo anterior.

Solución

  • Para evitar RQL el tiempo de espera de consulta, fílelo para escanear un segmento más pequeño, es decir, una cuenta o grupo de cuentas en particular.
  • En el siguiente ejemplo, cloud.account = ' Test'RDS AWS se agrega para filtrar la RQL consulta a una cuenta determinada.    

Imagen de usuario añadido



Additional Information



 


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004MHSCA2&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language