How to Avoid an RQL Query Timeout in the Investigate Tab in Prisma Cloud?
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Created On 11/09/21 04:09 AM - Last Modified 12/20/23 18:12 PM
Objective
- How to Avoid an RQL Query Timeout in the Investigate Tab in Prisma Cloud?
Environment
- Prisma Cloud
- RQL
Procedure
When running an RQL query in Investigate tab, the following message "No Results Available" may be encountered. This occurs during following scenarios:-
- No resources available in the onboarded cloud accounts to match the query.
- The RQL query timed out.
To confirm the above scenarios, consider the following examples.
- In RQL query 1, we only see the "No Results Available" message that indicates no cloud resources available to match this query
- However, in RQL query 2, with the "No Results Available" message we also see the 3 tabs pertaining to "Searches" below the query, that indicate an RQL query timeout.
RQL query 2 : Identify all running instances in "all onboarded cloud accounts" that are using an AMI not owned by managed accounts.
Cause
- When running an RQL query in Investigate tab, the backend will query the database for references that match the filter we input.
- In RQL query 2, the backend queried the database for resources in all onboarded cloud accounts matching the query
- In situations when there are too many resources to sort through in 3 mins, the RQL query may timeout, as seen in the above example.
Workaround
- To avoid RQL query to timeout, filter it to scan a smaller segment i.e. either a particular account or account group
- In the following example, cloud.account = 'RDS AWS Test' is added to filter the RQL query to a particular account.
Additional Information
See our documentation here for additional RQL examples.