Error: "The software manager is currently in use. Please try again later."

Error: "The software manager is currently in use. Please try again later."

20078
Created On 10/28/21 14:38 PM - Last Modified 03/18/22 02:04 AM


Symptom


  • PAN-OS Upgrade not allowed due to a Software Manager issue. Firewall is not able to install or delete actual software downloaded previously or download new software.
  • When trying to download, install or remove software the following error is displayed via GUI and CLI. Get error: "The software manager is currently in use. Please try again later."
  • Clicking 'Check Now' is working but it doesn’t fix the issue.
  • Checking the Management-Server log
> tail follow yes mp-log ms.log
Error:  pan_mgmtop_post_process_swimage(pan_ops_common.c:15014): failed to load /opt/pancfg/mgmt/sw-images/PanOS_5200-8.1.18 into swm
Error:  pan_mgmtop_post_process_swimage(pan_ops_common.c:15015): The software manager is currently in use. Please try again later.
Error:  pan_mgmtop_post_process_swimage(pan_ops_common.c:15016): Failed to load into software manager. Please retry.

 


Environment


  • Any platforms
  • Any Pan-OS


Cause


Failed to load into software manager, and the software manager is currently in use.

Resolution


From the CLI, unlock the software manager, by running this command:
> debug swm unlock

 


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004MA7CAM&lang=en_US%E2%80%A9&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language