Message d’erreur « Clé secrète client non valide fournie » sur Prisma Cloud

Message d’erreur « Clé secrète client non valide fournie » sur Prisma Cloud

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Created On 10/25/21 22:39 PM - Last Modified 04/30/25 19:29 PM


Symptom


  • Lorsque la clé secrète client d’application Azure expire sur le portail Azure, l’état du compte cloud s’affiche avec une erreur « Clé secrète client non valide fournie » dans la console Prisma.
  • L’expiration des clés secrètes client d’application sur le portail Azure peut entraîner l’affichage de la console Prisma avec une erreur « Clé secrète client fournie non valide ».


Environment


  • Prisma Cloud
  • Microsoft Azure


Cause


Tout espace supplémentaire ou erreur typographique lors de la copie de la clé de valeur à partir du portail Azure vers Prisma Cloud provoque une erreur « Clé secrète client fournie non valide ».

Remarque : DO NOT enregistrez la clé de valeur dans les applications de notes ordinaires et ne copiez pas les clés de valeur des notes ordinaires dans Prisma Cloud les paramètres du compte. La copie de la clé de valeur à partir d’une application de notes ordinaires peut modifier la syntaxe de la clé de valeur, ce qui est presque impossible à dépanner.La meilleure pratique consiste toujours à utiliser n’importe quelle application de programmation comme NotePad ++, Sublime, Code, VS pour enregistrer les clés de valeur.


Resolution


Console Prisma:

1. Connectez-vous à la console Prisma.
deux. Accédez à Paramètres > comptes cloud Cliquez sur le bouton Modifier dans Actions.


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3 . Cliquez sur le bouton Crayon pour voir la page Configurer le compte .

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4. Copiez l’application (client) ID dans n’importe quel bloc-notes. Nous l’utiliserons pour vérifier les inscriptions Azure dans le portail Azure App .

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Portail Microsoft Azure :

1 . Connectez-vous au portail Azure.
deux. Tapez App registration dans la barre de recherche . Cliquez ensuite sur App inscriptions.

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3.Recherchez Application (client) ID que nous avons copiée à partir de Prisma Cloud Cloud Account. Cliquez sur Application, Dans mon cas Prisma Cloud App qobyz

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4. Dans Prisma Cloud App qobyz , la vue d’ensemble indique "A le certificat ou le secret a expiré. Créez-en un nouveau ». Alors créez un nouveau secret.

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5. Sur le côté gauche, cliquez sur Certificat et secrets sous Gérer. Cliquez sur Nouvelle clé secrète client.

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6 . Remplissez les champs obligatoires pour la clé secrète client.

Note: Dans le menu déroulant Expire , utilisez la période requise selon vos besoins. 

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7. Copiez la valeur affichée sous Clés secrètes client.

Remarque: A la valeur de la clé secrète client n’est affichée qu’au moment de la création et après cela, elle n’est ni affichée ni récupérée. Ce que vous devez faire est de créer une nouvelle clé secrète client et de copier sa valeur lorsqu’elle est affichée.

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Console Prisma:

8. Remplacez l’ancienne valeur dans Clé secrète client d’application dans Prisma Cloud Compte. Cliquez sur Suivant

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9. Cliquez à nouveau sur Suivant pour voir Statut.

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10. Vous verrez un statut vert, cliquez sur Terminé.

Note: Si vous ne voyez pas l'état vert, attendez quelques minutes et répétez l'étape 7 à l'étape 10. Si vous n'avez pas configuré l'ingestion des journaux de flux. Il ne sera pas vert après avoir remplacé Value.

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11. Félicitations! Vous avez remplacé avec succès Client Secret Value.

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Additional Information


(Facultatif) Activer NSG les journaux de flux : si vous souhaitez activer l’ingestion des journaux de flux, vous devez effectuer les tâches décrites à l’étape 9

Actions
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