Mensaje de error "Se proporciona un secreto de cliente no válido" en Prisma Cloud
13404
Created On 10/25/21 22:39 PM - Last Modified 04/30/25 19:29 PM
Symptom
- Cuando el secreto de cliente de aplicación de Azure expira en el Portal de Azure, el estado de la cuenta en la nube aparece con el error "Se proporciona un secreto de cliente no válido" en la consola de Prisma.
- La caducidad de los secretos de cliente de aplicación en el Portal de Azure puede hacer que la consola de Prisma aparezca con el error " Secreto de cliente no válido proporcionado".
Environment
- Prisma Cloud
- Microsoft Azure
Cause
Cualquier error de espacio adicional o error tipográfico durante la copia de la clave de valor de Azure Portal causará Prisma Cloud un error
"Secreto de cliente no válido proporcionado". Nota: DO NOT guarde la clave de valor en aplicaciones de notas ordinarias y no copie las claves de valor de notas ordinarias en Prisma Cloud Configuración de cuenta. Copiar la clave de valor de la aplicación de notas ordinarias puede cambiar la sintaxis de la clave de valor, que es casi imposible de solucionar.Siempre la mejor práctica es utilizar cualquier aplicación de programación como NotePad++, Sublime, Code, VS para guardar las claves de valor.
Resolution
Consola Prisma:
1. Inicie sesión en la consola de Prisma.
número arábigo. Vaya a Configuración > Cuentas en la nube Haga clic en el botón Editar en Acciones.
3 . Haga clic en el botón Lápiz para ver la página Configurar cuenta .
4. Copie la aplicación (cliente) ID en cualquier bloc de notas. Lo usaremos para comprobar los registros de Azure en Azure App Portal.
Portal de Microsoft Azure:
número arábigo. Escriba App registro en la barra de búsqueda . Luego haga clic en App registros.
3.Busque la aplicación (cliente) ID que copiamos de Prisma Cloud Cloud Account. Haga clic en Aplicación, En mi caso Prisma Cloud App qobyz
4. En Prisma Cloud App qobyz Overview muestra "A certificado o secreto ha caducado. Crear uno nuevo". Así que crea un nuevo secreto.
5. En el lado izquierdo, haga clic en Certificado y secretos en Administrar. Haga clic en Nuevo secreto de cliente.
6 . Rellene los campos obligatorios para el secreto de cliente.
Nota: En el menú desplegable Caduca , utilice el período de tiempo requerido según sus requisitos.
7. Copie el valor que se muestra en Secretos de cliente.
Nota: A el valor del secreto de cliente solo se muestra en el momento de la creación y, después de eso, no se muestra ni se puede recuperar. Lo que tendría que hacer es crear un nuevo secreto de cliente y copiar su valor cuando se muestre.
Consola Prisma:
8. Reemplace el valor anterior en Secreto de cliente de aplicación en Prisma Cloud Cuenta. Haga clic en Siguiente
9. Haga clic en Siguiente de nuevo para ver el estado.
10. Verá un estado verde, haga clic en Listo.
Nota: Si no ve el estado verde, espere unos minutos y repita del paso 7 al 10. Si no configuraste la ingesta de registros de flujo. No será verde después de reemplazar Valor.
11. ¡Felicidades! Ha reemplazado correctamente el valor secreto de cliente.
Additional Information
(Opcional) Habilitar NSG registros de flujo: si desea habilitar la ingesta de registros de flujo, debe completar las tareas descritas en el paso 9