ユーザーが Prisma SaaSに Azure Cloud App をオンボードできない
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Created On 10/12/21 08:28 AM - Last Modified 01/07/25 06:14 AM
Symptom
- SaaSセキュリティ管理者ガイドの Azure Cloud App のオンボードに関する必須手順を完了した後、Azure Cloud App のオンボードが失敗します。
- 最後のステップでは、次のウィンドウで「次へ」ボタンをクリックします。
- メッセージなしで新しいウィンドウが開きます:
Environment
- プリズマSaaS
- オンボーディング
- Azure クラウド アプリ
Cause
- ストレージ アカウントの [安全な転送が必要] プロパティを設定することで、安全な接続からの要求のみを受け入れるように Azure ストレージ アカウントをコンフィグできます。
- 安全な転送が必要な場合、安全でない接続から発信されたリクエストはすべて拒否されます。
- Microsoft では、すべてのストレージ アカウントに対して常に安全な転送を要求することをお勧めします。
- ただし、この記事の執筆時点では Prisma SaaSアプリはHTTPS接続をサポートしておらず、 HTTP接続のみがサポートされています。
- このシナリオでは、自動検出マイクロサービスで次のログが表示されます。
5:25.259 [pool-5-thread-4] INFO c.p.a.a.s.i.DefaultAzureAutoDiscoveryService - Account being fetched does not support https. Subscription id 59830851-c50c-42fb-90ae-1ebd05cb1e04, tenantname: semprautilities1, csuid: fc1be5b7e4cf6efb822f4a8d37ee0e9d
Resolution
以下の手順に従って、Azure クラウド ストレージ設定でHTTPSオプションを無効にします。
- Azureポータルで既存のストレージ アカウントを選択します。
- ストレージ アカウント メニュー ペインの [設定] で、[構成] を選択します。
- [安全な転送が必要] の下で、[無効] を選択します。