User is unable to onboard Azure Cloud App on Prisma SaaS
3036
Created On 10/12/21 08:28 AM - Last Modified 09/24/24 22:32 PM
Symptom
- Onboard the Azure Cloud App fails after completing the required steps of SaaS Security Administrator's Guide for onboarding Azure Cloud App.
- In the final step a After one clicks Next button in the following window:
- A new window is opened without any messaging:
Environment
- Prisma SaaS
- Onboarding
- Azure Cloud App
Cause
- One can configure his Azure storage account to accept requests from secure connections only by setting the Secure transfer required property for the storage account.
- When secure transfer is required, any requests originating from an insecure connection are rejected.
- Microsoft recommends that you always require secure transfer for all of your storage accounts.
- However Prisma SaaS App doesn't support HTTPS connections at the time of writing this article and only HTTP connections are supported.
- The following log can be seen in autodiscovery microservice in this scenario:
5:25.259 [pool-5-thread-4] INFO c.p.a.a.s.i.DefaultAzureAutoDiscoveryService - Account being fetched does not support https. Subscription id 59830851-c50c-42fb-90ae-1ebd05cb1e04, tenantname: semprautilities1, csuid: fc1be5b7e4cf6efb822f4a8d37ee0e9d
Resolution
Disable HTTPS option in Azure cloud storage settings following the steps below:
- Select an existing storage account in the Azure portal.
- In the storage account menu pane, under Settings, select Configuration.
- Under Secure transfer required, select Disabled.