Panorama La connexion administrateur échoue avec l’erreur «SAML Échec de l’authentification unique » lors de l’utilisation de l’authentification unique Azure AD SAML (SSO)

Panorama La connexion administrateur échoue avec l’erreur «SAML Échec de l’authentification unique » lors de l’utilisation de l’authentification unique Azure AD SAML (SSO)

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Created On 08/31/21 18:11 PM - Last Modified 05/15/23 09:34 AM


Symptom


  • Panorama GUI login ne fonctionne pas avec l’authentification unique basée sur Azure.
  • Après avoir entré l’utilisateur et le mot de passe dans la page de connexion, le Panorama message d’erreur «SAML échec de l’authentification unique » s’affiche.

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  • Les messages « Échec de l’authentification pour l’utilisateur » s’affichent sous l’onglet Surveiller lorsque Panorama vous utilisez un autre utilisateur fonctionnel.

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Environment


  • Panorama
  • PAN-OS 10.0.4
  • Azure (authentification unique Azure AD SSO Active Directory)


Cause


Côté Azure AD , le « Type d’utilisateur » de l’utilisateur, ne correspond pas au type d’utilisateur de l’attribut « adminrole », sous la configuration Authentification unique. 

 


Resolution


  1. Dans AzureAD, au chemin d’accès suivant, Accueil > Palo Alto Networks - Admin UI > (Utilisateur), vérifiez le « Type d’utilisateur » de l’utilisateur.

Dans l'exemple ci-dessous, il est défini comme « Membre »:

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  1. Confirmez que sous Accueil > Palo Alto Networks - Admin UI > Single sign-on > User Attributes & Claims, nous avons créé un nouvel « attribut utilisateur » appelé « adminrole » :

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  1. Cliquez sur le bouton Modifier pour Attributs d’utilisateur et revendications et confirmez que le type d’utilisateur pour adminrole correspond au type d’utilisateur trouvé à l’étape # 1. Ils doivent correspondre.

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