Panorama Admin login fails with error "SAML Single-sign-on failed" when using Azure AD SAML Single Sign-on (SSO)
50167
Created On 08/31/21 18:11 PM - Last Modified 11/19/22 04:17 AM
Symptom
- Panorama GUI login fails to work with Azure-based Single Sign-on.
- After entering the user and password in the Panorama login page, error message "SAML single-sign-on failed" is seen.
- "Authentication failed for user" messages are seen under the Monitor tab for Panorama when using other working user.
Environment
- Panorama
- PAN-OS 10.0.4
- Azure AD SSO (Azure Active Directory Single Sign-on)
Cause
Azure AD side, the "User type" of the user, is not matching the User type of the "adminrole" attribute, under the Single sign-on configuration.
Resolution
- In Azure AD, at the following path, Home > Palo Alto Networks - Admin UI > (User), check the "User type" of the user.
In the below example, it's set as "Member":
- Confirm that under Home > Palo Alto Networks - Admin UI > Single sign-on > User Attributes & Claims, we have created a new "User Attribute" called "adminrole":
- Click on the Edit button for User Attributes & Claims and confirm that the User type for adminrole, matches the user type found in step # 1. They have to match.