Cloud Identity Engine Okta Directory 无法连接并出现错误“由于某些内部错误导致同步失败”
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Created On 08/30/21 03:13 AM - Last Modified 05/15/23 09:35 AM
Symptom
- A 新的 Okta 目录同步是使用 Cloud Identity 引擎设置的(CIE )
- 同步失败并显示错误“由于某些内部错误导致同步失败”
Environment
- 具有 Okta 目录设置的 Cloud Identity Engine
Cause
- 这是 Okta 的配置问题App在CIE无法连接到 Okta 目录。
- 查看配置参数以修复/调试问题。
- 尝试添加目录的用户不是管理员/只读管理员,不能允许CIE所需的范围。
- 这app在 okta 端没有正确配置。 联系 Okta 支持以确定供应商端是否观察到其他错误以及观察到哪些其他错误。
- 提供给的资料CIEhub页面存在 client-id 或 secret 可能错误的缺陷
- Okta 团队使用 refresh_token 确定了该问题。
Resolution
此时,一个习惯App需要在 Okta 端配置而不是默认集成app.
这将解决 Okta 方面的问题,并且 Cloud Identity 引擎现在可以连接到 Okta 并按预期同步用户/组。
Additional Information
有关 Okta 目录的配置注意事项的更多详细信息,请参见CIE, 使用以下文档。