Cloud Identity Engine Okta ディレクトリが「内部エラーのため同期に失敗しました」というエラーで接続できない
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Created On 08/30/21 03:13 AM - Last Modified 05/15/23 09:36 AM
Symptom
- A 新しい Okta ディレクトリ同期は Cloud Identity エンジン (CIE )
- 「内部エラーのため同期に失敗しました」というエラーが表示されて同期が失敗する
Environment
- Okta ディレクトリ設定を使用した Cloud Identity Engine
Cause
- これは構成の問題であり、OktaAppのCIEOkta ディレクトリに接続できません。
- 問題を修正/デバッグするには、構成パラメータを確認してください。
- ディレクトリを追加しようとしているユーザーは管理者/読み取り専用管理者ではないため、許可できませんCIE必要なスコープ。
- のappokta 側で正しく設定されていません。 Okta サポートに問い合わせて、ベンダー側で追加のエラーが検出されたかどうか、またどのようなエラーが検出されたかを特定してください。
- 提供された情報は、CIEhubページにはクライアント ID またはシークレットが間違っている可能性がある欠陥があります
- この問題は、Refresh_token を使用して Okta チームによって特定されました。
Resolution
この時点でのカスタムは、Appデフォルトの統合ではなく Okta 側で構成する必要があるapp。
これにより、Okta 側の問題が解決され、Cloud Identity エンジンが Okta に接続して、期待どおりにユーザー/グループを同期できるようになります。
Additional Information
Okta ディレクトリの構成に関する注意事項の詳細については、CIEの場合は、次のドキュメントを使用してください。