Cloud Identity Engine Okta Directory ne peut pas se connecter avec l’erreur « Échec de la synchronisation en raison d’une erreur interne »

Cloud Identity Engine Okta Directory ne peut pas se connecter avec l’erreur « Échec de la synchronisation en raison d’une erreur interne »

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Created On 08/30/21 03:13 AM - Last Modified 05/15/23 09:36 AM


Symptom


  • A la nouvelle synchronisation d’annuaires Okta est configurée avec le moteur Cloud Identity (CIE)
  • La synchronisation échoue avec l’erreur « Échec de la synchronisation en raison d’une erreur interne »
DRS Erreur de synchronisation


Environment


  • Cloud Identity Engine avec configuration de l’annuaire Okta


Cause


  • Il s’agit d’un problème de configuration où l’utilisateur Okta ne CIE parvient pas à se connecter à l’annuaire OktaApp.
  • Passez en revue les paramètres de configuration afin de corriger/déboguer le problème.
  • L’utilisateur qui essaie d’ajouter le répertoire n’est pas un administrateur / lecture seule et ne peut pas autoriser CIE les étendues nécessaires.
  • Le n’est app pas correctement configuré côté okta. Contactez le support Okta pour identifier si et quelles erreurs supplémentaires sont observées du côté du fournisseur.
  • Les informations fournies à CIE hub la page ont un défaut où l’ID client ou le secret peut être incorrect
  • Le problème a été identifié par l’équipe Okta avec le refresh_token.


Resolution


À ce stade, une personnalisation App doit être configurée côté Okta au lieu de l’intégration apppar défaut. 
Cela résoudrait les problèmes du côté d’Okta et le moteur Cloud Identity peut désormais se connecter à Okta et synchroniser les utilisateurs/groupes comme prévu.
 


Additional Information


Pour plus d’informations sur les mises en garde relatives à la configuration de l’annuaire Okta dans CIE, consultez la documentation suivante.

Configurer Okta en tant qu’IdP dans le moteur d’identité cloud



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