Error message: URL access error is seen when testing EDL

Error message: URL access error is seen when testing EDL

18820
Created On 07/23/21 08:11 AM - Last Modified 12/29/22 03:42 AM


Symptom


User-added image
 
  • When management-server debug  is enabled, ms.log displays HTTP code 404:
admin@PA-VM(active)> debug management-server on debug  => set management server to debug
admin@PA-VM(active)> less mp-log ms.log                => logs taken after using test source command
....
debug: pan_ebl_system_ebl_refresh_handler(pan_cfg_ebl.c:7838): EDL : curl_easy_perform passed, http_code(404)
Error:  pan_ebl_system_ebl_refresh_handler(pan_cfg_ebl.c:7844): EDL URL access error
....
admin@PA-VM(active)> debug management-server on info  => Reset management server to normal mode.


 


Environment


  • Any Palo Alto Firewall 
  • PAN-OS 8.1 and above
  • External Dynamic List (EDL) configured.


Cause


HTTP 404 error code indicates that the FW was able to communicate with the server, but the server could not find what was requested.
The error may also be used when a server does not wish to disclose whether it has the requested information.


Resolution


  1. Make sure the configured "Source" URL is correct. One can test accessing it from other sources.
  2. Make sure the server (source) will provide the requested list to the Firewall.


Additional Information


External Dynamic List

Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000001Vx5CAE&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language