获取服务列表时出错:Prisma access版本许可证功能不存在 插件验证失败 - Prisma Access
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Created On 07/23/21 02:14 AM - Last Modified 03/02/23 03:37 AM
Symptom
Panorama 正在管理Prisma Access环境,它正在生产中。 该插件开始显示验证失败错误,并且不允许管理员提交Prisma Access.
Error getting list of services: Prisma access edition license capabilities not present Failed plugin validation
Environment
Prisma Access 2.0或以上管理Panorama.
Cause
这通常是由于新的许可证添加/删除或许可证更新或过期的许可证仍然存在于系统中引起的。
Resolution
请按照以下步骤解决问题。
1:登录到PanoramaCLI//启用会话日志记录以保存输出。
>request license info. // To view the current licenses >delete license key. // Press Tab to view available and installed license keys. # Now delete any old expire licenses with respect to the Prisma, logging service or support services. >delete license key xxxx.key >request plugins cloud_services panorama-certificate delete. // This deletes the panorama certificate used to communicate to the prisma API >request license fetch. // Verify the licenses >request plugins cloud_services panorama-certificate fetch otp <OTP_KEY_FROM_SUPPORT_PORTAL>
注意:- 这些步骤不会删除任何配置或更改任何内容Prisma Access后端。
以下命令可以进一步验证连通性。
>request license info >debug plugins cloud_services prisma-access echo-test >request plugins cloud_services logging-service status
2:如果panorama在HA并且该问题仅适用于二次被动panorama虽然主要工作正常,但继续执行一些额外的步骤。
3:重启次要panorama管理服务。 管理服务最多可能需要 5 分钟才能恢复。
debug software restart process management-server
4:删除panorama证书。
request plugins cloud_services panorama-certificate delete
5:继续OTP再次验证,这将再次下载证书并验证许可证。
注意-:请记录上面完成的所有步骤CLI如果这些步骤不能解决会话数据的问题,请联系 Palo Alto 支持团队Panorama技术支持文件。
Additional Information
如果这些命令不能解决问题,请联系 Palo Alto 支持团队Panorama这些命令的技术支持报告和输出。