After installation/upgrade, GlobalProtect Windows app fails to connect to VPN with error : "The virtual adapter was not set up correctly due to a delay."

After installation/upgrade, GlobalProtect Windows app fails to connect to VPN with error : "The virtual adapter was not set up correctly due to a delay."

132326
Created On 07/12/21 09:48 AM - Last Modified 11/03/22 20:39 PM


Symptom


  • The GlobalProtect application seems to be installed or upgraded successfully.
  • The GlobalProtect application loads successfully and prompts for user credentials(if required).
  • The GlobalProtect VPN connection fails with the following error message: "The virtual adapter was not set up correctly due to a delay. GlobalProtect will try again soon. If the issue persists, try restarting your system."
  • Rebooting the workstation does not make any difference.
  • The GlobalProtect virtual adapter is not listed under the network adapters of Windows 10 workstation.
  • Exploring the GlobalProtect logs file; setupapi.dev.log indicates following code for the PanGpd network driver installation job:
>>>  [Install network driver - PanGpd]
>>>  Section start 2021/07/07 10:21:04.940

     ... DETAILED LOGS TRUNCATED FOR READABILITY OF THIS ARTICLE ...

<<<  Section end 2021/07/07 10:21:06.646
<<<  [Exit status: FAILURE(0x80070005)]


Environment


  • Palo Alto Firewall
  • Supported PAN-OS
  • GlobalProtect Agent/App on Windows 
  • Any other network or security related application installed on the workstation ( Endpoint security application /  VPN application)


Cause


  • The failed exit status along with error code 0x80070005 primarily indicates lack of access/privilege for GlobalProtect virtual adapter driver installation.
  • These kind of restrictions/interferences for device driver installation are usually introduced by other security applications installed on the system.


Resolution


  1. Disable or if possible completely remove the security application from workstation.
  2. Reboot the workstation.
  3. Install or upgrade the GlobalProtect application.


Additional Information


Download and Install the GlobalProtect App for Windows
How To Collect Logs From GlobalProtect Clients



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000001VqnCAE&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language