GlobalProtect App stays in 'Connecting...' status and never connects for new macOS device
36114
Created On 07/09/21 22:47 PM - Last Modified 03/04/23 03:12 AM
Symptom
After installing GlobalProtect App on macOS for the first time, when trying to connect to GlobalProtect, GlobalProtect Client stays in 'Connecting...' status and never connects.
PanGPS.log shows:
Info ( 777): Migrate settings
Info ( 228): Couldn't obtain debug level from settings
Info ( 260): PrelogonEnabled is 0
Info ( 262): Daemon process needs to quit since prelogin is disabled
Info ( 555): StartPanAgent() failed
Info ( 228): Couldn't obtain debug level from settings
Info ( 260): PrelogonEnabled is 0
Info ( 262): Daemon process needs to quit since prelogin is disabled
Info ( 555): StartPanAgent() failed
PanGPA.log shows:
Info ( 228): InitConnection ...
Debug( 57): fd still open before connect
Error( 80): CPanSocket::Connect - Failed to connect to server at port:4767
Error( 232): Cannot connect to service, error: 61
Debug(1270): CPanCommand::Send - not connected, and reintialized connection to service
Debug( 57): fd still open before connect
Error( 80): CPanSocket::Connect - Failed to connect to server at port:4767
Error( 232): Cannot connect to service, error: 61
Debug(1270): CPanCommand::Send - not connected, and reintialized connection to service
Environment
- GlobalProtect App
- macOS
Cause
The GlobalProtect has two processes:
- PanGPS
- PanGPA
The PanGPA process connects and communicates with the PanGPS over TCP Port 4767
If this communication is blocked due to system policies, permissions, or third-party applications, the GP App would not be able to communicate with the GP Portal and Gateway
Resolution
Troubleshoot macOS system settings, like:
1. Check the macOS Security & Privacy
2. Check the macOS firewall rules
3. Check the 3rd-party endpoint security applications not blocking communication over TCP 4767