GlobalProtect 卸载消息“不允许卸载,请联系您的IT行政人员!”
25417
Created On 06/17/21 12:19 PM - Last Modified 04/11/23 01:21 AM
Symptom
- GlobalProtect 无法卸载并失败并显示消息:不允许卸载,请联系您IT行政人员!
- 一旦你点击 'OK ' 弹出一个新窗口,其中包含不同的消息:此 Windows 安装程序包有问题。 A 作为设置的一部分运行的程序未按预期完成。 请联系您的支持人员或软件包供应商。
Environment
- GlobalProtect App 适用于 Windows
Cause
这个问题可以在什么时候看到GlobalProtect门户有配置允许用户卸载GlobalProtectApp(仅限 Windows)设置 '不允许'.
什么时候GlobalProtectAgent 正在连接到 Portal,它将获取 Agent 配置。 在 PanGPA.log 文件中可以看到:
HOW TO COLLECT LOGS FROM GLOBALPROTECT CLIENTS
<agent-config name="agent-config">
<save-user-credentials>1</save-user-credentials>
<portal-2fa>no</portal-2fa>
<snip>
<uninstall>disabled</uninstall>
<snip>Resolution
- GUI:网络 >GlobalProtect >门户网站> <GlobalProtect -门户配置> >代理人> <代理配置> ->App标签。
- 改变允许用户卸载GlobalProtectApp(仅限 Windows)到'允许'
- 来自GlobalProtect客户端,刷新连接以便GlobalProtect从门户中获取新配置的代理。
- 然后尝试卸载 GlobalProtect
Additional Information
允许用户卸载GlobalProtectApp- 指定是否允许用户卸载GlobalProtectapp如果是这样,他们在卸载之前必须做什么(如果有的话)app :
- 允许 - 允许任何用户卸载GlobalProtectapp如所须。
- Disallow — 不允许最终用户卸载GlobalProtectapp.
- Allow with Password — 强制输入密码以卸载GlobalProtectapp. 此选项要求用户在继续卸载之前输入并确认密码。 您可以通过电子邮件或在您组织的网站上发布来提供密码。